Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 08-22-2012, 05:26 PM
FrontLiner FrontLiner is offline
LawnSite Member
 
Join Date: Mar 2011
Location: Jamison, PA
Posts: 2
Echo 280s won't start anymore. Any advice?

I have an Echo 280s that I purchased brand new in May of 2011. I started having problems with it about a month ago. It started with the typical bogging down. I bought a carb rebuild kit, changed the fuel lines and filters, spark plug was also replaced. After all that, I had the same result. I then took the muffler off and checked for build up. There was a little carbon so I cleared that out and still the same problem persisted. I left it alone for a week and now it won't start at all. I know it is a big NO NO to use Ether on small engines but I tried anyways, still nothing.

It has spark, right fuel mixture, new fuel lines and filters, carb has been cleaned. Where do I go from here?

Also, I tried taking the muffler off and starting it and fuel was shutting out of the exhaust for a few pulls.

Any advice would be greatly appreciated because I have no idea where to go from here. I'm dumbfounded
Reply With Quote
  #2  
Old 08-22-2012, 09:03 PM
ed2hess's Avatar
ed2hess ed2hess is online now
LawnSite Fanatic
 
Join Date: Nov 2002
Location: Austin Texas 78727
Posts: 11,655
Quote:
Originally Posted by FrontLiner View Post
I have an Echo 280s that I purchased brand new in May of 2011. I started having problems with it about a month ago. It started with the typical bogging down. I bought a carb rebuild kit, changed the fuel lines and filters, spark plug was also replaced. After all that, I had the same result. I then took the muffler off and checked for build up. There was a little carbon so I cleared that out and still the same problem persisted. I left it alone for a week and now it won't start at all. I know it is a big NO NO to use Ether on small engines but I tried anyways, still nothing.

It has spark, right fuel mixture, new fuel lines and filters, carb has been cleaned. Where do I go from here?

Also, I tried taking the muffler off and starting it and fuel was shutting out of the exhaust for a few pulls.

Any advice would be greatly appreciated because I have no idea where to go from here. I'm dumbfounded
When you took the muffler off did you check to see if the exhaust was full of carbon? If 280 has a muffler screen take it out. The next step is to get the anti tamper plugs off the 2 needle valves and adjust them.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 11:58 PM.

Page generated in 0.06524 seconds with 9 queries