Register free!


 
 
Thread Tools   Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 09-01-2012, 01:51 PM
BPS##'s Avatar
BPS## BPS## is offline
LawnSite Senior Member
 
Join Date: Aug 2011
Location: WY
Posts: 828
Way high PSI woes

So one of my apartments (first year contract for me, 15 yr old property) had 135/140 psi at the backflow. Soon as I realized this I immediately put in a request for a pressure regulator. Bid was approved and installed.
Prior to this we'd get leaks and breaks that were pretty obvious it was from high PSI water hammer on the lines.



Now that the regulator has been in I'm changing out A LOT of formerly working heads. 2 cases of RB 5000s and counting, in just one month.
Whats the deal with this? Any body else run into a similar situation?


The best I can come up with as to why they were working and now they aren't is from my help. He wondered if the pressure was so high that it forced a lot of sand/grit past the filters and even tho it was gumming up the works the super high pressure kept the heads working. Now that the pressure is back to more manageable levels the heads just won't work.


Thoughts????????
__________________
Professionals are people who can do their job when they don't feel like it.
Amateurs are people that can't do their job even when they do feel like it.
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump






Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 01:20 PM.

Page generated in 0.09387 seconds with 8 queries