Register free!

The Green Industry's Resource Center


 
 
Thread Tools   Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 09-14-2012, 09:51 PM
Bunton Guy's Avatar
Bunton Guy Bunton Guy is offline
LawnSite Bronze Member
 
Join Date: Sep 2001
Location: charlotte nc
Posts: 1,662
Low oil light

Bought a brand new hustler trimstar 54" with kawasaki electric start engine

After the first hour of use the low oil red light came on while parking the mower. I let it sit for 30 minutes then checked the level....and it was right at the "add" line Hopefully that didn't hurt the brand new motor?

I added fresh oil and on my way I go....30 minutes later im done mowing and I bring the engine down to idle and the red light comes on again. I do the same and check the level and it was right at full mark. I then tested it and everytime I brought the throttle up the light went out. Bring the throttle back down to idle and the red light comes on.

Now im sure I would need to bring the mower into the dealership but I already have bad blood with the dealer. He is the closest Hustler dealer to me but he turns away most of the "warranty" issues I have had with my other Hustler super Z telling me that " hustler won't fix that under warranty" I've complained about 3-4 other things that have had issues with that should be under warranty and he denies all of them. Im sure whatever is wrong with this mower now I will be covering out of my own pocket.

What could this be? Mower has right at 4 hours on it now.
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Layout Style:





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 05:19 AM.

Page generated in 0.06797 seconds with 8 queries