Register free!

The Green Industry's Resource Center



 
 
Thread Tools   Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 09-24-2012, 05:57 AM
JLSLLC's Avatar
JLSLLC JLSLLC is offline
LawnSite Senior Member
 
Join Date: Aug 2011
Location: Gloucester County NJ
Posts: 255
Charging system running at 12 Volts, alternator good- F350

Thanks for checking my post out, I have a 1987 f350 dump i just bought. Its a 460 4 speed tank. Im working on it, fixing it up when i can..etc...So the truck has 12v running with no accessories on.. Wont get any higher I had the alternator checked, and it passed. I checked the wiring to the alt and it seems to be newer and in good shape, good connections, and the battery is brand new. It just doesnt seems right to me, ive always seen vehicles charging system run at 14.5 plus Volts... Im thinking of checking the power wire that goes to the starter and battery, see if theres a voltage drop there, and also check grounds and corrosion. Anybody ever run into this?
__________________
J.L.S. LLC
Licensed & Insured
Serving South Jersey
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 01:23 AM.

Page generated in 0.06646 seconds with 8 queries