Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 09-28-2012, 06:33 PM
mow4cash mow4cash is offline
LawnSite Member
 
Join Date: Oct 2009
Location: Poughkeepsie, Ny
Posts: 101
Scag turf tiger hydro/wheel motor failure

I noticed my left side hydro was making some extra noise. When the mower was cool it was fine but after 30 min it would get worse and loose power. I also felt like the side started to freewheel at high speeds. It kinda felt like the grass was real slippery and hard to keep the mower steady.

After a full day of pushing the mower it gave out on a hill. I think the filter clogged up. The whole system is contaminated with metal flakes. I did notice the right side sticking a little before the failure probably because all the metal flakes were in there. At this point I have flushed the wheel motors and cleaned the reservoir.

I am leaning towards replacing both hydro's to be on the safe side. I was told I could probably clean out the right side hydro and it would probably be ok. I am still wondering if this could have been a wheel motor failure and don't know anyway to check them.

Any way to check the wheel motors?
Are my new pumps safe to try if it was a wheel motor failure?
Can I flush the cooler and the rest of the lines by catching it on the return line?
Can the right side contaminate the left side If I only replace the left hydro to to see if the right is still good?
Any other ideas or suggestions?
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 06:17 PM.

Page generated in 0.06503 seconds with 8 queries