Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 10-04-2012, 11:41 AM
ron mexico75's Avatar
ron mexico75 ron mexico75 is offline
LawnSite Bronze Member
 
Join Date: May 2009
Posts: 1,404
Belt drive owners

So as some might know, I posted a couple weeks ago about an issue with the way my belt drive mower was performing. Its a 36" Exmark Metro. Whenever I would go up an incline the mower would basically slow to a crawl and then just stop even though the belts were turning. I'd have to push with all my might and then BAM! it would start pulling again. Got to the point where the belt jusrt kept slipping to the inner side of the tire against the frame.

Ended up taking it to the dealer and they said one of the pulley's was out of alignment and that it works now. Well when I got it back it was like brand new. Very strong pull, went up the inclines good.

Well, it seems to have returned to hesitating......kind of. I was using my accelerator catcher on it at 2 properties yesterday. While going up some very minimal inclines it started to lag again like it didn't want to go.

Could this have been due to the extra weight of the grass in the catcher along with the turf being slightly damp? I guess what I'm asking is, is this normal for a belt drive and that's what hydro's have over them is they don't "slip" and hesitate?

Do any of you experience some hesitation while going up inclines with a catcher or hesitation going up hills without the catcher when it's wet or damp?

Im starting to get very annoyed at this but wanted to check and see what you guys have to say to make sure I'm not losing my cool over something that is normal with a belt drive.

Is it the pulley and belt not having the best of friction because it is damp? Is it because going up hill against gravity isn't best suited for a belt drive but more for a hydro? Is "some" hesitaion normal?

Any opinions are appreciated.
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 02:59 AM.

Page generated in 0.11901 seconds with 8 queries