Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 12-15-2012, 09:20 AM
MisterBreeze MisterBreeze is offline
LawnSite Member
 
Join Date: Dec 2010
Location: Union County, NC
Posts: 73
Wright Stander RH 52" Ignition Switch

I turn the switch (key) to the off position and it takes 1-2 seconds to actually kill the engine. I changed out the switch and the problem continues. Any ideas?
Reply With Quote
  #2  
Old 12-15-2012, 10:19 AM
BigFish's Avatar
BigFish BigFish is offline
LawnSite Bronze Member
 
Join Date: Jul 2008
Location: chesapeake, va
Posts: 1,609
Check the harness plugs. The mag kill wire is white. Also check the black ground wire at the plugs and at the eng block. Got a loose connection/terminal somewhere along the line.
Click on the Wright logo and then support. You should be able to download an owners manual that has a wire diagram.
__________________
" But let me tell you something ,folks: You can't fix stupid! There's not a pill you can take, there's not a class you can go to. Stupid is forever!"

......AMF!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 04:32 AM.

Page generated in 0.05981 seconds with 9 queries