Register free!

The Green Industry's Resource Center



 
 
Thread Tools   Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 01-22-2013, 03:38 PM
ddixon7 ddixon7 is offline
LawnSite Senior Member
 
Join Date: Dec 2011
Posts: 339
Exmark Turf Tracer Stiff

I have bought 9 brand new Turf Tracers and Turf Tracer HPs over the years. The last one I bought (a 60" with 24hp Kaw) is not very responsive in the Hydros. It has good ground speed in forward and reverse, but is not very "snappy" if that makes sense. The triggers do not return fast enough for my liking. I have had this problem before but it is usually a break in deal. After about 200 hours they seem to be outstanding. This one is now 2 years old with 1300 hours on it. The triggers are as sluggish as ever.

Anyone had this problem? Like I said, this is the first Turf Tracer I have had like this. Any adjustments that you guys know of? Stiff springs? I don't think it would be a pump or wheel motor issue. It has to be within the trigger mechanism itself I would think.

I also have a brand new S series (hp) 52" and it is already very snappy. It is just weird.
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 07:06 AM.

Page generated in 0.06615 seconds with 8 queries