Register free!
Search
 
     

Click for Weather
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 03-18-2013, 09:07 PM
big daddy b's Avatar
big daddy b big daddy b is offline
LawnSite Member
 
Join Date: Dec 2010
Location: East Syracuse, NY
Posts: 95
REPAIR: Plate Tamper doesn't vibrate

Might be the wrong forum for this, but hey I figured most everyone of you have owned and operated numerous tampers before so maybe someone can help me out here with some information....
I have a big old plate tamper, I literally pulled it out of the garbage and brough it home. Touched up the paint on it, used it a few times.
Not sure what brand of tamper this is, no name on it and no serial numbers anywhere besides the honda engine.

So anyway, the engine fires right up the first pull, no issues at all there.
The issue I am having is the belt does not turn, which does not run the gears in the box below so it doesn't vibrate. I don't know why.

I know nothing about tampers or how they actually function, other than how to start it up and change oil. I don't know about the tamper part.

What is in that cylinder? gears? crankshaft? what kind of oil should I be using in that. Because i'm pretty sure it's low on oil in that department, maybe it dried up and got locked up in there, I am not sure.

What should I do, in your opinion?
I know it's only $100, but it's more of an annoyance for me because I am not positive how to fix it yet, and not sure if it is fact even fixable.
It was one of those things where I used it one day, it worked perfectly, the next time I went to use a month later...it didn't work at all. I know that's a long time for it to sit not being used, but hey.

So, any opinions? Words of advice other than to throw it back in the garbage? Anyone have this happen to them?
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump






Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 08:52 AM.

Page generated in 0.09028 seconds with 9 queries