Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 04-06-2013, 03:19 PM
steheap steheap is offline
LawnSite Member
 
Join Date: Sep 2010
Location: Virginia
Posts: 10
Honda GXV620 engine - uneven running

I have a 6 year old Hustler Fastrak mower with Honda GXV620 engine. Last season it was sometimes running unevenly and lacking power - unsteady noise from the engine - and would slow and almost stop with the blades turning on an incline. I changed the air filter and foam filter and that seemed to fix the issue. It then started again right at the end of the season. I could simply remove and replace the same filter and the next time it would be OK.

Over the winter, I replaced the air filter, fuel filter, spark plugs, but when I had completed all that, the first time I started it, it still stuttered, but I put new gasoline in, and the next start was fine. I did a bit of mowing and put it away. This morning - same thing - uneven, lacking power.

I hadn't checked the spark plug gaps, and so I took one out, checked it (OK) and put it back in. Next start - it was fine and I mowed for an hour.

I'm not confident that I have actually found the issue though - it almost seems to be that doing something around the engine fixes it, but after a rest, it is back to low power again!

Any ideas?

steve
Reply With Quote
 

Tags
gxv620 , honda , lacks power , uneven

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 06:36 AM.

Page generated in 0.08375 seconds with 8 queries