Register free!

The Green Industry's Resource Center



Reply
 
Thread Tools   Display Modes
  #1  
Old 06-19-2013, 01:12 PM
RugerRedhawk RugerRedhawk is offline
LawnSite Member
 
Join Date: Sep 2008
Posts: 74
Briggs 190cc clunking when I pull, and won't start

Was making some clunking noise, I suspected it was a result of hitting a rock or a stick and fearing a bent shaft, but it kept running just loud. Well it finally gave up and now it won't start. When I pull there is a clunk in the engine. Anything in particular to look for? Blade turns freely.
Reply With Quote
  #2  
Old 06-19-2013, 01:38 PM
gunsnroses's Avatar
gunsnroses gunsnroses is offline
LawnSite Senior Member
 
Join Date: Aug 2009
Posts: 259
Sounds bad, hey!

I am guessing a push mower. If you cant fix it, yer probably better off buying new.
Reply With Quote
  #3  
Old 06-19-2013, 01:45 PM
RugerRedhawk RugerRedhawk is offline
LawnSite Member
 
Join Date: Sep 2008
Posts: 74
Quote:
Originally Posted by gunsnroses View Post
Sounds bad, hey!

I am guessing a push mower. If you cant fix it, yer probably better off buying new.
Yeah I'd like to give it a go and see if it's something I can fix, if not I'll buy another of course. I have about 5 days before time to mow again!
Reply With Quote
  #4  
Old 06-19-2013, 10:16 PM
windflower windflower is offline
LawnSite Senior Member
 
Join Date: Feb 2013
Location: wilmington nc
Posts: 795
Sounds like the connecting rod may be toast. Pretty easy to replace if you have the time. If it broke other parts may be damaged.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 07:02 AM.

Page generated in 0.06712 seconds with 9 queries