Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 09-05-2003, 10:18 PM
SJH Landscaping SJH Landscaping is offline
LawnSite Member
 
Join Date: Oct 2002
Location: Pittsburgh
Posts: 31
Lacking Power

I have a 4 hp Commerical 21" Snapper that has been lacking power when mowing. As soon I start to cut it bogs down on me. I cleaned the air filter, spark plug, checked the oil (which I do everyday), and even tried to adjust the mix on the carb. But, still no success. Any Suggestions?
Reply With Quote
  #2  
Old 09-06-2003, 12:26 AM
RELIABLELAWNMAN RELIABLELAWNMAN is offline
LawnSite Member
 
Join Date: Mar 2002
Location: FRESNO, CA
Posts: 149
Make sure that the carb. jets are clean. Had a similar problem with a Kawasaki FC150 on my Toro 21" and that solved my problem.
Reply With Quote
  #3  
Old 09-06-2003, 12:55 PM
NCSERVICE's Avatar
NCSERVICE NCSERVICE is offline
LawnSite Member
 
Join Date: Aug 2003
Location: Raleigh North Carolina
Posts: 206
carb.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 02:50 AM.

Page generated in 0.06708 seconds with 9 queries