Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 07-04-2013, 12:01 AM
Camaro865 Camaro865 is offline
LawnSite Member
 
Join Date: Nov 2006
Location: New York
Posts: 54
03 silverado fuel pressure regulator?

just today my truck wont start first try after sitting a while. if i shut it off and try to start it right away it starts fine. if it sits i have to try twice. i bought this truck 4 years ago and it had the same problem at that time and the dealer said it was the fuel pressure regulator bleeding down and its was in the tank. they fixed it before i bought it.

can anyone confirm this or is it something under the hood? i really dont want to dig into the tank. by the way its a 6 liter


thanks!!
Reply With Quote
  #2  
Old 07-04-2013, 12:17 AM
HPI_Savage25 HPI_Savage25 is offline
LawnSite Member
 
Join Date: Sep 2012
Location: Martinez, GA
Posts: 192
03 silverado fuel pressure regulator?

Try this, when you first hop in the truck, instead of turning all the way to start the truck turn it where the fuel pump comes on but doesn't turn over. Do that two or three times while waiting in between to allow the fuel pump to prime. After the 2nd or 3rd time try to start it and see what it does.
__________________
2003 Silverado 1500HD
7x16 enclosed trailer
Walker GHS 36"
Encore Premier 36" WB
Reply With Quote
  #3  
Old 07-04-2013, 12:44 AM
Camaro865 Camaro865 is offline
LawnSite Member
 
Join Date: Nov 2006
Location: New York
Posts: 54
Quote:
Originally Posted by HPI_Savage25 View Post
Try this, when you first hop in the truck, instead of turning all the way to start the truck turn it where the fuel pump comes on but doesn't turn over. Do that two or three times while waiting in between to allow the fuel pump to prime. After the 2nd or 3rd time try to start it and see what it does.
it starts up normal if i do that
Reply With Quote
  #4  
Old 07-04-2013, 07:30 AM
GE734's Avatar
GE734 GE734 is offline
LawnSite Member
 
Join Date: Jun 2013
Location: Plymouth MI
Posts: 18
My 03 suburban had the same problem, threw in a new fuel pump assembly and fuel filter and it runs like a champ, it could be the regulator though, not 100% sure
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 12:20 AM.

Page generated in 0.06841 seconds with 9 queries