Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 07-03-2013, 11:07 AM
timgren timgren is offline
LawnSite Member
 
Join Date: Jul 2013
Location: Wentzville MO
Posts: 11
Trimstar Rescue or Retire?

Hello folks.
I recently picked up a Hustler Trimstar (or pre-trimstar?) from a farm auction. My wife calls it "the beast", and thinks im crazy. (nothing new). The unit is in ROUGH condition, but have been wanting something like this for a while to cut my own property. After getting it home and giving it a good look, I'm starting to wonder if this was a wise purchase. I'm torn if I should invest the time/money is bring it back to life again or just part it out. I only paid $200 for it. My interest is about having a working mower that can produce a professional cut, not making money. But there are limits of course. I can't afford a new one.

The unit has a 48" deck, and a Kohler CV624S engine (225 hours) + a sulky. No idea of it's age. The engine cranks when carb cleaner is shot down the intake but dies after a few seconds. This is what gave me hope. What's VERY clear is the original owner was not fond of maintaining his equipment. I was planning to do an engine overhaul this weekend, but now wondering if it will quickly become a money pit.

Observations:
- The air cleaner (hd type) is glued shut. (apparently he broke the retainer clips and solved the problem with RTV sealant)
- Fuel filter removed and bypassed. Fuel lines are shot.
- Has oil cooling unit, but fins are clogged with grim and not sure if oil flows.
- Operator presence system bypassed. (wires cut)
- No Battery
- Unit starts to move in reverse when h-bar is locked in neutral (tells me the hydro's are working, but needs adjustment)
- Probably sat for 3-4 years with gas in it.
- road tar would best describe the oil condition. Looks like an original oil filter.
- Blades are.. undescribable. Looks like he tried to cut stones with it.
- No covers for deck.
- Side Discharge flapper is bent/cracked, but could be re-welded.
- 1 flat drive tire, 1 flat guide tire
- Belts look good
- Idlers are questionable. hand turned only, but the bearings arent smooth turning.
- Blade bearings seem ok.
- No oil or hydro leaks that I can tell.
- Hydro oil tank is full, oil is clean, but not sure if the oil is the correct type.
- Sulky is in good shape.

So - what do you think? Worthy of repair? I'm not afraid to invest money in it if I can get some long-term value out of it, or at least recover my "investment" on the resale market.


I currently use a Kabota B7500 with a mid-deck which runs great, but I have never liked the cut and the kubota tires (AG4) tends to cause too much turf damage.

I'd be VERY interested in a professionals opinion.
Reply With Quote
  #2  
Old 07-05-2013, 04:03 PM
Pierre2013 Pierre2013 is offline
LawnSite Senior Member
 
Join Date: Jun 2013
Posts: 584
Given you got it for $200, imo, it would be premature to discard it for parts.

If it were me, I would change ALL filters and ALL liquids before trying to get the engine to run. Use a spare car battery or buy one from Costco (cheap). Worst case scenario, you will have to take the carb apart and clean it very carefully. I had to do that with a Honda lawnmower (damn Honda carbs! - more sensitive than a woman :O ).

I think the first step is finding out if the engine is OK. Don't forget to check the cranckase breather hose (I think it has one???). If not, sell it for parts. If the engine is fine, then you can look into what it will cost to get it in top shape. Just my 2 non-professional cents
Reply With Quote
  #3  
Old 07-05-2013, 04:10 PM
monoshock's Avatar
monoshock monoshock is offline
LawnSite Senior Member
 
Join Date: Jun 2011
Location: Lake City TN. is that banjos I here?
Posts: 788
I never liked the controls on a trimstar. But that's just me.
__________________
Tim
Reply With Quote
  #4  
Old 07-05-2013, 05:06 PM
TriCountyLawn's Avatar
TriCountyLawn TriCountyLawn is offline
LawnSite Bronze Member
 
Join Date: Aug 2005
Location: NW Indiana
Posts: 1,518
Pretty low hours, These are pretty good mowers as well. Im surprised you dont like the controls as I got rid of other brand mowers for this reason. Each their own .lol

If you want to bail on it let me know , I will give ya 200 for it. Good luck.
Reply With Quote
  #5  
Old 07-07-2013, 09:42 PM
timgren timgren is offline
LawnSite Member
 
Join Date: Jul 2013
Location: Wentzville MO
Posts: 11
Update - Ok, I checked the compression and that was good, so I decided to dive-in head first, Fix or fail.

I replaced the failed fuel pump, added a fuel filter, all new fuel lines, cleaned and rebuild the carb, changed plugs (even they were the wrong type! lol ), changed the oil and filter, replaced cracking remote oil-cooler lines, cleaned the gas tank and discovered a split in the plastic under the strap - now patched, flushed out the breather, added a new battery, and bought a brand new HD air filter assembly.

$240 later, She now cold starts in less then 2 seconds without using the choke at all and at low idle. Purrs at a constant 1100 rpm idle speed.

Of course starting it exposed all sort of NEW issues. Valve cover gaskets needed to be replaced, electrical harness was in such tatters (cracks/splits/ adhoc splices, etc) that I decided to build a new one using the OEM wiring schematic and correct wire (color and gauge). Even replaced the key switch since it too was in poor working condition. Operator presence, and neutral lock switch now work properly.

Hydros are in good condition, good power, and the oil looks ok, but I'll be changing this out soon as well. With all the other red-neck style "fixes", I'm going to assume the oil type is incorrect. Does anyone have a cross-reference number for the hydro oil filter?

OK, so I just HAD to take it for a test drive. She ran well. I was very impressed with the power and speed. Controls seem a little jerky, but im sure they can be dialed in once I get to that part. Nice power up/down the hills, the deck starts nicely and the idlers seem ok. The clutch is good and once I gave the drive spindles some much-needed grease they also ran well. No more squeals. I used my bench grinder to clean up the blades to just run a test cut. Not too shabby.

I am having a hard time finding replacement blades locally, so I'll have to order them online. Seems the only blades available online is the stock blade - OEM #767111. I was hoping to get Gators, or high lift blade for mulching. Does anyone have an any recommendations for blades?? Also - would the 48" Mulch Kit - 344788 fit this deck??

The model I have is #925669. How can anyone tell me when this model series was produced? I'm just looking to piece together some history.

Thanks again for the encouragement to move forward. I'm pretty pleased with the results so far. Now just new tires, blades, deck covers, and she be good as new. Definitely a keeper!!
Reply With Quote
  #6  
Old 07-07-2013, 10:08 PM
GrassGuerilla GrassGuerilla is offline
LawnSite Bronze Member
 
Join Date: Aug 2008
Location: St. Louis Missouri
Posts: 1,418
Maybe a bit rough, but 250 hours on what was a $6000 machine there. Sounds like a steal to me. Balloon tires? Donaldson air filter? Seperate pumps and wheel motors or integrated?
Posted via Mobile Device

Edit:$5300, but still...
Reply With Quote
  #7  
Old 07-08-2013, 11:25 AM
Pierre2013 Pierre2013 is offline
LawnSite Senior Member
 
Join Date: Jun 2013
Posts: 584
Quote:
Originally Posted by timgren View Post
Update - Ok, I checked the compression and that was good, so I decided to dive-in head first, Fix or fail.

I replaced the failed fuel pump, added a fuel filter, all new fuel lines, cleaned and rebuild the carb, changed plugs (even they were the wrong type! lol ), changed the oil and filter, replaced cracking remote oil-cooler lines, cleaned the gas tank and discovered a split in the plastic under the strap - now patched, flushed out the breather, added a new battery, and bought a brand new HD air filter assembly.

$240 later, She now cold starts in less then 2 seconds without using the choke at all and at low idle. Purrs at a constant 1100 rpm idle speed.

Of course starting it exposed all sort of NEW issues. Valve cover gaskets needed to be replaced, electrical harness was in such tatters (cracks/splits/ adhoc splices, etc) that I decided to build a new one using the OEM wiring schematic and correct wire (color and gauge). Even replaced the key switch since it too was in poor working condition. Operator presence, and neutral lock switch now work properly.

Hydros are in good condition, good power, and the oil looks ok, but I'll be changing this out soon as well. With all the other red-neck style "fixes", I'm going to assume the oil type is incorrect. Does anyone have a cross-reference number for the hydro oil filter?

OK, so I just HAD to take it for a test drive. She ran well. I was very impressed with the power and speed. Controls seem a little jerky, but im sure they can be dialed in once I get to that part. Nice power up/down the hills, the deck starts nicely and the idlers seem ok. The clutch is good and once I gave the drive spindles some much-needed grease they also ran well. No more squeals. I used my bench grinder to clean up the blades to just run a test cut. Not too shabby.

I am having a hard time finding replacement blades locally, so I'll have to order them online. Seems the only blades available online is the stock blade - OEM #767111. I was hoping to get Gators, or high lift blade for mulching. Does anyone have an any recommendations for blades?? Also - would the 48" Mulch Kit - 344788 fit this deck??

The model I have is #925669. How can anyone tell me when this model series was produced? I'm just looking to piece together some history.

Thanks again for the encouragement to move forward. I'm pretty pleased with the results so far. Now just new tires, blades, deck covers, and she be good as new. Definitely a keeper!!

I'm really happy for you. When you initially wrote that the belt looked good and it only 225 hours on the meter, I felt you had a great mower that simply needed some proper maintenance. Once you are done fixing it, you will have a great mower for less than a thousand box.

I strongly suggest you write to Hustler directly for most of your remaining questions. I had to deal with them directly and got unbelievable help. You can write to either, or both, Service and Parts. Good luck and happy mowing.

http://www.hustlerturf.com/contact/contact/service.html

http://www.hustlerturf.com/contact/contact/parts.html
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 01:23 PM.

Page generated in 0.06584 seconds with 9 queries