Register free!

The Green Industry's Resource Center


 
 
Thread Tools   Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 07-31-2013, 05:00 PM
gtclark gtclark is offline
LawnSite Member
 
Join Date: Sep 2007
Location: Lampasas, Texas
Posts: 2
Mini Z won't start

Ok, my 5 year old Huslter Mini Z decided that it didn't want to start today. Since it had the original battery still in it I thought that it might be the culprit. I changed the battery out and it still won't even attempt to turn over.

I'm not sure if it's the starter or what. It has the Kawasaki 19hp engine and the only problem that I have had was a bad PTO/Blade switch that I had to replace.

I have tried everything I know to get it started. The park switches appear to be working correctly along with the seat sensor. When I have the key in the start position the engine will not start but when I engage the PTO/Blade switch there is a loud click indicating that the PTO/Blade has engaged. It also clicks when I disengage the PTO/Blade switch.

Has my starter gone south?
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Layout Style:





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 08:04 AM.

Page generated in 0.06877 seconds with 9 queries