Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 08-08-2013, 12:58 PM
davelobi davelobi is offline
LawnSite Member
 
Join Date: Aug 2013
Posts: 2
Husqvarna zero-turn dies when blades engaged

I have a Z4217 Husqvarna with the 17.5 hp Briggs Intek.
It is cutting out (dying) quite often while mowing.
If I keep cutting when it starts dying it will shut right down.
If I stop it will usually catch back up and keep running.
Usually, if I disengage the blades it will stay running and dies more if blades are left running.
I can't quite tell if it is cutting out electrically or fuel related but it seems electrical to me.
I have removed and cleaned the carb but didn't find anything suspect there. Fuel filter flows freely. Gas cap is vented and free.

Is there common things I can look for? I wonder about the multitude of electrical connections with the many safety switches everywhere.

Thanks in advance for your wisdom or ideas.
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 06:32 PM.

Page generated in 0.07775 seconds with 8 queries