Register free!
Search
 
     

Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 08-28-2013, 08:52 PM
Zohan Zohan is offline
LawnSite Member
 
Join Date: Mar 2011
Posts: 135
Anyone else having issues with Kichler LED fixtures?

Got call from client I installed a year ago. Fixture not working...i go check it out and there is water in the lens area.....
Here is the fixture, it's a PATH fixture.
http://www.kichler.com/products/prod...-15800azt.aspx

WTH......so i replace it, that was 2 weeks ago. Today i get a call that the same fixture is out along with the one next to it....

These things are supposed to have a 15 year guarantee and be sealed....

Anyone else?
Might have stop speccing Kichler immediately.....
Hopefully someone from Kichler will see this and contact me...
__________________
Reply With Quote
  #2  
Old 08-30-2013, 03:41 PM
starry night's Avatar
starry night starry night is online now
LawnSite Silver Member
 
Join Date: Feb 2009
Location: Ohio's North Coast
Posts: 2,060
Sorry, Zohan, I think you may have missed the boat with this post.
__________________
Phil Bauer
Starry Night Lighting


"This little light of mine, I'm gonna let it shine."
Reply With Quote
  #3  
Old 08-30-2013, 03:47 PM
Zohan Zohan is offline
LawnSite Member
 
Join Date: Mar 2011
Posts: 135
Quote:
Originally Posted by starry night View Post
Sorry, Zohan, I think you may have missed the boat with this post.
Please elaborate?
__________________
Reply With Quote
  #4  
Old 08-30-2013, 06:08 PM
starry night's Avatar
starry night starry night is online now
LawnSite Silver Member
 
Join Date: Feb 2009
Location: Ohio's North Coast
Posts: 2,060
Quote:
Originally Posted by Zohan View Post
Please elaborate?
The Kichler boat to the Carribean or wherever they're going this year.
__________________
Phil Bauer
Starry Night Lighting


"This little light of mine, I'm gonna let it shine."
Reply With Quote
  #5  
Old 08-30-2013, 10:00 PM
Drakeslayer Drakeslayer is offline
LawnSite Member
 
Join Date: Apr 2013
Posts: 125
Quote:
Originally Posted by Zohan View Post
Got call from client I installed a year ago. Fixture not working...i go check it out and there is water in the lens area.....
Here is the fixture, it's a PATH fixture.
http://www.kichler.com/products/prod...-15800azt.aspx

WTH......so i replace it, that was 2 weeks ago. Today i get a call that the same fixture is out along with the one next to it....

These things are supposed to have a 15 year guarantee and be sealed....

Anyone else?
Might have stop speccing Kichler immediately.....
Hopefully someone from Kichler will see this and contact me...
Why don't you contact them instead. Or make you distributor handle it. Just a thought.
Reply With Quote
  #6  
Old 08-31-2013, 08:32 PM
Zohan Zohan is offline
LawnSite Member
 
Join Date: Mar 2011
Posts: 135
Because in the past that didnt work. This time was different though, and I was contacted, thx
__________________
Reply With Quote
  #7  
Old 09-02-2013, 09:55 PM
Irrigation Contractor Irrigation Contractor is offline
LawnSite Senior Member
 
Join Date: Nov 2011
Location: South East
Posts: 253
Quote:
Originally Posted by Zohan View Post
Got call from client I installed a year ago. Fixture not working...i go check it out and there is water in the lens area.....
Here is the fixture, it's a PATH fixture.
http://www.kichler.com/products/prod...-15800azt.aspx

WTH......so i replace it, that was 2 weeks ago. Today i get a call that the same fixture is out along with the one next to it....

These things are supposed to have a 15 year guarantee and be sealed....

Anyone else?
Might have stop speccing Kichler immediately.....
Hopefully someone from Kichler will see this and contact me...
We have had only one fixture failure since we began using Kichler. We did not spend the time investigating the cause for the basic reason it was on one out of hundreds of units.

I will ask my lighting manager and maybe he can give me some details.
Reply With Quote
  #8  
Old 09-12-2013, 04:06 AM
JimLewis's Avatar
JimLewis JimLewis is offline
LawnSite Fanatic
 
Join Date: Dec 1999
Location: Beaverton, OR
Posts: 6,393
I've installed hundreds of the Kichler LED pathway lights over the last 2-3 years. I've only had one fail, where I couldn't figure out why (the other two were hit by a bike or a car). In this case, the light just started flickering and eventually stopped working about 10 days after the install. Not sure why. Couldn't see any water intrusion or broken wires or anything apparent. I just returned it and got a new one. Easy over-the-counter swap. But that's the only issue I've ever had with one of them.

I've had more problems with the accent lights (spot lights) in the Design Pro LED series (e.g. the 15733, 15743, etc.). No issues with water getting in. The only issue I've had is the damn set screw breaking. And you cannot replace it when that happens. Just need to replace the entire fixture. Had a big lighting install last week with like 40 fixtures, and 2 of them broke right off the bat. We aren't ranking on them either. They just break sometimes. I hate that part of those fixtures.

As if this week, we're only using the new Radiax line. Those don't have a set screw in the back, line their previous line. We've installed a good 100 or so of the radiax accent/spot lights so far this year and haven't had one problem with them at all. I love the way they adjust compared to the crappy set screw on the old ones. Plus, I like the warmer color temperature (2700 K for the new ones vs. 3000 with the older ones) and I like the fact that they come with a cowl already too.

I am curious as to why you had two go bad like that. I haven't ever used that particular path light. We have always installed the 15810AZT, 15820AZT and the 15839TZT for all the installs we've ever done. And as I said before, never a problem with those, except the one time.
__________________
Jim Lewis
Lewis Landscape Services - Oregon
"kickin' grass and takin' names"


www.lewislandscape.com - Portland Oregon Landscaping Company

landscape design Portland Oregon
Reply With Quote
  #9  
Old 09-12-2013, 05:58 AM
Zohan Zohan is offline
LawnSite Member
 
Join Date: Mar 2011
Posts: 135
There is a known issue (within Kichler) that the 15800 had an issue with water getting in if there is a sprinkler head within a few feet. With this one there was.
The other fixture I'm just chalking up to be defective....
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump






Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 10:54 AM.

Page generated in 0.06885 seconds with 9 queries