Register free!
Search
 
     

Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 09-14-2013, 09:46 PM
MySide MySide is offline
LawnSite Member
 
Join Date: Feb 2010
Location: Cape Girardeau, MO
Posts: 32
Permagreen Magnum sprayer output

I have a 2008 Permagreen Magnum B2B spreader sprayer, bought used 2 years ago with 40 hours on it. I've only spread with it so far but want to start spraying. It's running 3600 RPM and I read where it shouldn't go over 3450, but the tach quit on me today. So help on that is accepted.
Question is: How wide is your sprayer spraying? How many gallons per thousand square feet are you getting? When I drive it down the driveway spraying -- low gear, high gear sprayer nozzle -- it doesn't cover the drive very well. I'm concerned about getting adequate coverage / results.
Thanks!
Reply With Quote
  #2  
Old 09-15-2013, 11:13 AM
RigglePLC's Avatar
RigglePLC RigglePLC is online now
LawnSite Fanatic
 
Join Date: Jul 2006
Location: Grand Rapids MI
Posts: 9,269
Rpm 3600 is fine--ideal in my opinion. A Honda can handle it. Use high gear. With a little luck you should be covering around 11 square feet wide. Allow for a bit of overlap and you should cover about 5 feet out on both sides, 10 feet effective swath.
Not sure, I think your output should be about one-third of a gallon per thousand sqft, (about 43 ounces).
At 4 miles per hour,(352 feet per minute) if you cover a ten foot swath, you cover 3520 sqft per minute.
You need 151 ounces output per minute, (about 1.2 gallons per minute).

This will work fine. No need to soak the weeds with water. Lightly wet is fine. Let the chemistry do the work. If you are worried about the amount of solution...drive in low gear for the first few weeks (after adjusting to a suitable tank concentration).
Reply With Quote
  #3  
Old 09-15-2013, 08:16 PM
MySide MySide is offline
LawnSite Member
 
Join Date: Feb 2010
Location: Cape Girardeau, MO
Posts: 32
thanks! may need a new pump. only getting a gallon a minute and not spraying quite that wide. I wish they had a 3-4 nozzle boom option.
Reply With Quote
  #4  
Old 09-16-2013, 11:04 PM
gebby gebby is online now
LawnSite Senior Member
 
Join Date: Nov 2009
Location: COLUMBUS, OHIO
Posts: 635
Check to make sure that the pulley and the belt are both tight enough. My key on my pulley had loosened on me earlier this year. That pulley also runs the spreader. Check your nozzles for any blockage. If you have any type of filter(s) make sure they are also clean. Any lines kinked? Its something simple. Put it in neutral, sit still and pull the sprayer at full throttle, measure your width. It should be 11 ft. or close to it. I have a book that tells how much approximately that should come out. If you ask 10 different guys, I'll bet you get 10 different answers. Most guys adjust to their piece of equipment. Since the pump hasn't been used much, anything is possible. Just my opinion
Reply With Quote
  #5  
Old 09-16-2013, 11:12 PM
gebby gebby is online now
LawnSite Senior Member
 
Join Date: Nov 2009
Location: COLUMBUS, OHIO
Posts: 635
The book says 90 oz. in 60 seconds in high gear at 3450 rpm's using the wide spread. The last time I checked mine I was at 78 oz./60 seconds at 3450 rpm's. I'm getting along just fine. It's been that way for 3 years. As Riggle said let the chemical do it's job.
Reply With Quote
  #6  
Old 09-17-2013, 07:50 PM
MySide MySide is offline
LawnSite Member
 
Join Date: Feb 2010
Location: Cape Girardeau, MO
Posts: 32
Thanks to all of you. lines are good. cleaned nozzles and screens even on pickup line in tank. only getting 7' effective spray width. tach started working again. maybe it got wet when cleaning it. guy at permagreen sure isn't any help! will check pulleys and belts, but they seemed tight when i looked at them. Will try it and see what results i get.
Reply With Quote
  #7  
Old 09-17-2013, 10:32 PM
gebby gebby is online now
LawnSite Senior Member
 
Join Date: Nov 2009
Location: COLUMBUS, OHIO
Posts: 635
Yesterday I said to check the key on the pully. I should have said the set screw. Small allen wrench needed. I'd get the rmp's up there above 3450, open the valve at the bottom and see how many oz. you get out of that in 60 seconds. There is half a dozen things you can check. The belt could be slipping. Do a search on this sight. At the top there is a search engine. Your question has been brought up many times. I think there also is a diagram of the Magnum on their web sight. As you mentioned your pump may be shot if you haven't used it for a while. Wish you luck.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 10:40 AM.

Page generated in 0.06435 seconds with 9 queries