Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 09-21-2013, 07:39 PM
TML's Avatar
TML TML is online now
LawnSite Senior Member
 
Join Date: Oct 2012
Location: Southern, ME
Posts: 604
2000 Chevy 2500 6.0 low coolant

I have the above truck it was when they were switching styles and mine is the newer 2500 with the 6.0 (but not the HD 8600). The low coolant light has been coming on and at best it appears to be down 8oz or so if anything. I brought it into the shop I've always used and they initially said small pin hole in water pump. They then called back and said upon further review they were not sure it was the water pump and honestly said they could not pin point the leak. Suggested wait until it becomes more pronounced. This was after they were given the go ahead to replace the pump.

This has happened again and I can see no obvious leak and the coolant is only down a cup full or so. I put a dash in and the light goes off next time I start it. I can't imagine the sensor is that sensitive???

Couple of people have said replace the cap??

Or is this just another electrical chevy glitch I've had a few with this truck but it runs like a top 128K.

We know it is not going into the engine the oil has been checked and is fine thankfully.
Posted via Mobile Device
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 09:58 AM.

Page generated in 0.10386 seconds with 8 queries