Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #11  
Old 01-22-2014, 07:35 PM
BigFish's Avatar
BigFish BigFish is offline
LawnSite Bronze Member
 
Join Date: Jul 2008
Location: chesapeake, va
Posts: 1,640
Quote:
Originally Posted by BigFish View Post
I've not worked on any Kaw. dfi units, but, as mentioned, it sure sounds like a gov. issue. The part about running OK with the blades on ( loaded) is one symptom.
Is the gov link spring in place? Its the small coil spring around the link rod and hooked into throt. and gov levers. It helps take up any slop in the linkage. Are you working with the Kaw. shop manual? If so, it has a pretty detailed gov section.
Actually I meant to say the Fuel System pages 2-8 thru 2-10
__________________
" But let me tell you something ,folks: You can't fix stupid! There's not a pill you can take, there's not a class you can go to. Stupid is forever!"

......AMF!
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 04:47 AM.

Page generated in 0.11025 seconds with 8 queries