Register free!

The Green Industry's Resource Center


Reply
 
Thread Tools   Display Modes
  #11  
Old 03-23-2014, 04:19 PM
HPSInc HPSInc is online now
LawnSite Senior Member
 
Join Date: Nov 2010
Location: Buffalo, NY
Posts: 440
Your probably fine as for not needing new hydro pumps. Just fix your leaks. I had a leak on my scag with only 10 hours on it. o-ring failed, and replacements kept failing after a week or two. Dealer was no help, bunch of jerk offs and I wont buy from them again. Tried putting me on a waiting list of over a week to fix my brand new mower that I need daily. No offer of a demo unit to use in the mean time. I finally got it to stop when I put in a new O-ring and sileconed the crap out of the surrounding area after installing the line back. Not pretty but hasn't leaked since.
Reply With Quote
  #12  
Old 03-23-2014, 10:22 PM
M&T M&T is offline
LawnSite Member
 
Join Date: Feb 2013
Posts: 23
Quote:
Originally Posted by HPSInc View Post
Your probably fine as for not needing new hydro pumps. Just fix your leaks. I had a leak on my scag with only 10 hours on it. o-ring failed, and replacements kept failing after a week or two. Dealer was no help, bunch of jerk offs and I wont buy from them again. Tried putting me on a waiting list of over a week to fix my brand new mower that I need daily. No offer of a demo unit to use in the mean time. I finally got it to stop when I put in a new O-ring and sileconed the crap out of the surrounding area after installing the line back. Not pretty but hasn't leaked since.
Wow!!!! It's amazing how some dealers just don't care about the customer. I have one of those close to where I live and I would not spend a penny in their shop.
Posted via Mobile Device
Reply With Quote
  #13  
Old 03-24-2014, 07:23 PM
MSlawnBoy MSlawnBoy is offline
LawnSite Member
 
Join Date: Jun 2009
Location: Madison, Ms
Posts: 99
tHANKS TO all for the help! Put 4 new hoses on and she is driving better than new! No more leaks!

And thanks on the tip with going to NAPA to get the hoses! That saved me 100 bucks!! So thank you. All 4 of the hoses were leaking, some worse than others.

All is good, wheeewww.

I'm still not sure what caused this, but it may have something to do with a lot of grass clippings and debris built up between the tires and the hoses?? It's hard to clean out with your hand, but you can bet I'll find something to use to keep that area clean!
__________________
______________________
Ferris IS 2000Z - 52"/25HP Kaw

Last edited by MSlawnBoy; 03-24-2014 at 07:27 PM.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 11:00 PM.

Page generated in 0.06500 seconds with 9 queries