search sponsored by:
Advanced Search

The Green Industry's Resource Center

Old 04-29-2014, 05:43 PM
milo's Avatar
milo milo is offline
LawnSite Bronze Member
Join Date: May 2005
Location: Allentown PA
Posts: 1,200
any issues with new style toro g3 exmark all in one hydro system?

im looking at used 09 toro g3. just wondering if these wheel / pump setup has any issues? I never heard of any but wonder.
Reply With Quote
Old 05-05-2014, 04:48 AM
KFLAWN KFLAWN is offline
LawnSite Member
Join Date: Dec 2009
Location: Mi
Posts: 224
We had a trim side go at 900 hrs. Otherside has 1700. Exmark next gen.
Posted via Mobile Device
Reply With Quote
Old 05-05-2014, 05:47 AM
Mickhippy's Avatar
Mickhippy Mickhippy is offline
LawnSite Platinum Member
Join Date: Feb 2003
Location: Queensland, Australia.
Posts: 4,120
A friend has one with over 3500 hrs sometimes cutting seriously rough and steep stuff. No problem but may of broken an axel at around 2000hrs or something. He seemed to think the hydros themselves were fine.
You guys would freak if you saw the stuff he's done with it. If that hydro held up to it, that says A LOT IMHO.
Reply With Quote
Old 05-05-2014, 04:10 PM
american dream american dream is online now
LawnSite Senior Member
Join Date: Apr 2007
Location: murfreesboro, tn
Posts: 268
I just had my right unit go out at 1270hr what a crock 70 hr out of warranty and always used toro oil and filters.
Posted via Mobile Device
Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Layout Style:

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 01:28 PM.

Page generated in 0.06374 seconds with 10 queries