Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #11  
Old 09-23-2013, 10:44 PM
GreazyThumbs GreazyThumbs is offline
LawnSite Member
 
Join Date: Sep 2013
Location: Aurora, OH
Posts: 3
GulfJoe, I have the same issue. What did you find out was the problem and was it resolved. I would be interested in your findings??
Reply With Quote
  #12  
Old 09-24-2013, 05:37 AM
gulfjoe's Avatar
gulfjoe gulfjoe is offline
LawnSite Bronze Member
 
Join Date: Mar 2009
Location: Columbus GA
Posts: 1,004
Quote:
Originally Posted by GreazyThumbs View Post
GulfJoe, I have the same issue. What did you find out was the problem and was it resolved. I would be interested in your findings??
I contacted the distributor in my area, and he sent all new parts and had the local warranty shop install it all and it was all good up until a few weeks ago. The rattle started again, so since I am a jet engine mechanic full time and have access to lots of cool tools and machinist were fabricated a nylon bushing to go in where they have that rubber one. It has seemed to work but I just installed it this weekend. I will keep you updated. I am seriously thinking about selling this thing in the off season.
Posted via Mobile Device
Reply With Quote
  #13  
Old 09-24-2013, 12:43 PM
GreazyThumbs GreazyThumbs is offline
LawnSite Member
 
Join Date: Sep 2013
Location: Aurora, OH
Posts: 3
What parts were the culprit if you can remember off hand, and were they hard to get from a dealer? I notice mine rattles only at low idle when the unit is warming up or I have it in neutral and waiting. It goes away when I am running full bore. My dealer said it is natural b/c there is some play for the floating deck. But it does not sound right to me. But the unit is cutting well enough.

Let me know the parts if you can? Maybe you will have to go into business manufacturing those bushings...
Reply With Quote
  #14  
Old 09-24-2013, 02:03 PM
gulfjoe's Avatar
gulfjoe gulfjoe is offline
LawnSite Bronze Member
 
Join Date: Mar 2009
Location: Columbus GA
Posts: 1,004
Quote:
Originally Posted by GreazyThumbs View Post
What parts were the culprit if you can remember off hand, and were they hard to get from a dealer? I notice mine rattles only at low idle when the unit is warming up or I have it in neutral and waiting. It goes away when I am running full bore. My dealer said it is natural b/c there is some play for the floating deck. But it does not sound right to me. But the unit is cutting well enough.

Let me know the parts if you can? Maybe you will have to go into business manufacturing those bushings...
I got the splined shaft, the spindle it splined in to the connector bolt that is mounted to the deck and new hardware. They told me that some of these mowers came with an out of round pulley from the factory and they are aware of the problem.
Posted via Mobile Device
Reply With Quote
  #15  
Old 09-24-2013, 09:34 PM
GreazyThumbs GreazyThumbs is offline
LawnSite Member
 
Join Date: Sep 2013
Location: Aurora, OH
Posts: 3
Can you IM me your contact at world lawn, I will try and give them a call.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 05:39 PM.

Page generated in 0.05812 seconds with 10 queries