Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #51  
Old 04-11-2013, 07:58 PM
Mickhippy's Avatar
Mickhippy Mickhippy is offline
LawnSite Gold Member
 
Join Date: Feb 2003
Location: Queensland, Australia.
Posts: 3,899
Quote:
Originally Posted by Ridin' Green View Post
Mick has had some serious problems with his 60" VX4 deck, and so has greenology.

Neither have been taken care of like they should be from the manu or importers over there. There have been several posts about them not cutting well here either, especially on northern grasses. puppy obviously likes his, but he is running a larger version of the VX4 than Mick and green.
Exactly!

Im blown away that there aren't more complaints!
Reply With Quote
  #52  
Old 04-11-2013, 11:38 PM
greenology's Avatar
greenology greenology is offline
LawnSite Senior Member
 
Join Date: Oct 2012
Location: Sydney, Australia
Posts: 811
Quote:
Originally Posted by Mickhippy View Post
Exactly!

Im blown away that there aren't more complaints!
Its such a frustrating thing to be dealing with! if only there were more complaining we would be able to get somewhere, but in the meantime we are treated like just some fussy wingers.

The thing is, the squeeky door gets the oil, so we need to keep squeeking!
Reply With Quote
  #53  
Old 04-11-2013, 11:48 PM
Choppin Choppin is offline
LawnSite Senior Member
 
Join Date: Mar 2013
Location: crossett, ar
Posts: 526
Or just get a Ferris or Deere and be done with Hustler... Just my thoughts.. But i bet it is frustrating to pay that much for a machine and have trouble with them...
Posted via Mobile Device
Reply With Quote
  #54  
Old 04-12-2013, 01:36 AM
Mickhippy's Avatar
Mickhippy Mickhippy is offline
LawnSite Gold Member
 
Join Date: Feb 2003
Location: Queensland, Australia.
Posts: 3,899
Quote:
Originally Posted by Choppin View Post
Or just get a Ferris or Deere and be done with Hustler... Just my thoughts.. But i bet it is frustrating to pay that much for a machine and have trouble with them...
Posted via Mobile Device
Not an option at this moment. I owe to much on it (or would loose to much), its coming to end of the season and I doubt anyone would buy it!
Reply With Quote
  #55  
Old 08-14-2013, 03:55 AM
moaboy moaboy is offline
LawnSite Member
 
Join Date: Jan 2010
Location: new zealand
Posts: 8
Well guys, i think we might have it beaten. We had noticed that the electric clutch didn't click in properly when the switch was activated, but thought that the pulleys might be the reason for the belts breaking. The reason that it has taken so long is because of changing a pulley, trying it and move on to the next one when a belt would break. We changed the clutch and so far we have done nearly 90 hours with no breaks. The meacanic who changed the clutch said that my one seamed to be ok, but that it was still hot to the touch even tho the machine hadn't been going for over an hour. Hopefully we have fixed the problem
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 04:54 AM.

Page generated in 0.06063 seconds with 10 queries