Register free!

The Green Industry's Resource Center


Reply
 
Thread Tools   Display Modes
  #11  
Old 08-27-2014, 11:15 PM
atlantistom atlantistom is offline
LawnSite Member
 
Join Date: Jul 2011
Location: Kissimmee FL
Posts: 14
Wow, Cimkill, That sucks! Do you have insurance?
I'm not sure if you remember me.
I bought my ferris from Lou a few weeks after you and just had to bring it in due to a faulty regulator causing 3' flames to shoot out the exhaust. The worst part is I only have 89 hours on the unit and just had to shell out $350!
I obviously don't use it commercially.
I'm appealing to Ferris to see if there's any corporate kindness in the world...
Funny thing is, from day one, it always took like ten seconds to fire. with the new reg. it takes like three seconds. I always assumed it was the oil pressure switch.

Do you know what your RPM is at full throttle? I was at 3880 with the faulty regulator now I'm at 3550. I feel the loss of power in the thick grass.
Reply With Quote
  #12  
Old 08-27-2014, 11:26 PM
Patriot Services's Avatar
Patriot Services Patriot Services is online now
LawnSite Fanatic
 
Join Date: Jul 2006
Location: Tampa FL
Posts: 8,656
Quote:
Originally Posted by BIG NICKY View Post
they sell propane powered ice augers that run on the little Coleman tanks. so i would guess only a matter of time before little propane trimmers and such hit the market.

Whats an ice auger you ask? (southern guys)
its for those of us in the north who want to be able to fish in the winter on top of a frozen lake.
Come on now. Its the same damn thing we use to bore fence pole or small tree holes.
Posted via Mobile Device
Reply With Quote
  #13  
Old 08-27-2014, 11:28 PM
Patriot Services's Avatar
Patriot Services Patriot Services is online now
LawnSite Fanatic
 
Join Date: Jul 2006
Location: Tampa FL
Posts: 8,656
Quote:
Originally Posted by atlantistom View Post
Wow, Cimkill, That sucks! Do you have insurance?
I'm not sure if you remember me.
I bought my ferris from Lou a few weeks after you and just had to bring it in due to a faulty regulator causing 3' flames to shoot out the exhaust. The worst part is I only have 89 hours on the unit and just had to shell out $350!
I obviously don't use it commercially.
I'm appealing to Ferris to see if there's any corporate kindness in the world...
Funny thing is, from day one, it always took like ten seconds to fire. with the new reg. it takes like three seconds. I always assumed it was the oil pressure switch.

Do you know what your RPM is at full throttle? I was at 3880 with the faulty regulator now I'm at 3550. I feel the loss of power in the thick grass.
3ft exhaust flames? Why would you ever want to fix that? Id be putting twin stacks on it.
Posted via Mobile Device
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 04:41 PM.

Page generated in 0.05540 seconds with 10 queries