Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 04-29-2005, 07:19 PM
ed2hess's Avatar
ed2hess ed2hess is offline
LawnSite Fanatic
 
Join Date: Nov 2002
Location: Austin Texas 78727
Posts: 11,487
Walker Hydrostatic Drive-Rebuild?

I am still trying to determine if a Walker Hydrostatic drive can be rebuilt. I have learned it is built by Eaton. My Walker manual shows some parts for the input shaft side(gear/bearing/seal etc.). It has been suggested that you can't open the system but since Walker sells bearings and seal this suggests otherwise. Has any of you Walker guys had one rebuilt?? And has anybody used JD Thomas replacement part?
Reply With Quote
  #2  
Old 05-01-2005, 12:52 AM
fixer67's Avatar
fixer67 fixer67 is offline
LawnSite Silver Member
 
Join Date: Apr 2004
Location: Tryon NC
Posts: 2,161
The input shaft and input shaft bearing are replaced by removing the input pulley and then removing a snap ring and PULLING them out from the OUTSIDE. You DO NOT take the pump apart to replace the input shaft and input bearing. If you ever did take pump apart you would need a press to put it back together. The put has 5 or is it 6 pistons that are spring loaded. You remove the bolts that hold the pump housing halves together and you will have parts flying all over the place. Now I have not took one apart but that is what Walker and Eaton has told us. I have replaced the input shaft and bearing on these pumps before. Some special tools are needed to make it easy to do. And I thank that the pumps that JD Thomas sells are Eaton pumps. This sounds like I have read your post before, did you post this on a Yahoo group?
__________________
"DEFECTIVE OWNER/OPERATOR NOT COVERED UNDER WARRANTY"
Reply With Quote
  #3  
Old 05-01-2005, 12:15 PM
ed2hess's Avatar
ed2hess ed2hess is offline
LawnSite Fanatic
 
Join Date: Nov 2002
Location: Austin Texas 78727
Posts: 11,487
Thanks for response yes I asked about this before...I have not taken the hyro out yet but there is a slight leak. It donesn't sound like fixing the leak will have any affect on the drive(surging on and off). I am concerned about how to be sure that I have a hydro problem and not the downstream drive train. I intend to put it in garage and jack it up and release pressure and roll it over to be sure it all rotates freely...any thing else I can do.
Reply With Quote
  #4  
Old 05-01-2005, 01:02 PM
Triple L's Avatar
Triple L Triple L is online now
LawnSite Senior Member
 
Join Date: Dec 2004
Location: Kitchener, Ontario
Posts: 348
hay, I got a 2004 walker that i bought brand new and it's got 275 hours on it now, ever since the beginning when I get the hydros hot like after mowing for more then 30 min. it gets sloppy. I can drive on a perfectly flat road and at full speed it will drive straight then it seem that the left hydro will kick out for a second and the mower will start going to the left then it will kick in and jerk to the right and it will constantly keep doing it. I told my dealer and had them check it out but they could not really find anything wrong. The mechanic said that there is something wrong but not major and he dosent want to put a new hydro in it because if eaton says there's nothing wrong with it then it comes out of his pocket. Does anyone know what might be wrong with the hydros or what i can do to fix it. It's really gettin me mad because its pretty hard to make a straight line for striping a property. thanks.
__________________
CLT (Certified Landscape Technician)
The trucks are Chev's and the tractors Green
Reply With Quote
  #5  
Old 05-01-2005, 09:25 PM
ed2hess's Avatar
ed2hess ed2hess is offline
LawnSite Fanatic
 
Join Date: Nov 2002
Location: Austin Texas 78727
Posts: 11,487
That is the same symption that I have...it kicks out for just a short time. But if I try backing up a ramp on my trailer I have to pull the handle back almost all the way back on the side that ocassionally fails. Since those actuating lever are spring loaded back to normal, if they fail to go back after you actuate on side you could get a delay in action. So if you pull back on one side and it don't return immediately you will get a jerk when it pops back forward. That is what yours sounds like. But in my case the unit won't drive back and that can't be in the actuating arms since it is a solid condition. Don't know if this makes sense
Reply With Quote
  #6  
Old 05-01-2005, 10:49 PM
fixer67's Avatar
fixer67 fixer67 is offline
LawnSite Silver Member
 
Join Date: Apr 2004
Location: Tryon NC
Posts: 2,161
Quote:
Originally Posted by ed2hess
Thanks for response yes I asked about this before...I have not taken the hyro out yet but there is a slight leak. It donesn't sound like fixing the leak will have any affect on the drive(surging on and off). I am concerned about how to be sure that I have a hydro problem and not the downstream drive train. I intend to put it in garage and jack it up and release pressure and roll it over to be sure it all rotates freely...any thing else I can do.
There is nothing down stream that really can go bad. If it did you would hear one he$$ of a noise because the final drive is ALL steel gears on steel gears. I have a Walker in the shop right now that is doing the same thing on the right side. A pump has been ordered and I will be putting it in some time this week (when it come in). I will let you know how it goes.
Attached Images
 
__________________
"DEFECTIVE OWNER/OPERATOR NOT COVERED UNDER WARRANTY"
Reply With Quote
  #7  
Old 05-01-2005, 11:19 PM
Jason Rose's Avatar
Jason Rose Jason Rose is offline
LawnSite Fanatic
 
Join Date: Jan 2003
Location: Hutchinson, Kansas
Posts: 5,777
a couple of the situations mentioned, about the hydro wanting to slow down or stop when hot. Sounds like an air leak somewhere... Like air is somehow getting into the fluid or the fluid itself is foaming for some reason. I know walkers are mostly sealed and have no oil lines so how the sir could be getting in there is beyond me, but it's something to think about.

I give idea because it happened to me on my 50" dixon. hydros would work fine, then suddenly one side or the other would shutter or as it got worse totally stop. I'd disengage the drive to the pumps, reengague it and it would work fine for a bit. I wnt thru the system and tightned a few clamps on hoses and replaced the fliter, which was leaking fluid, and put new mobile 15-50 in it. Now it works just like new again. Where exactly the air was getting in I dunno, but that was my mechanics guess and he was right.
Reply With Quote
  #8  
Old 05-02-2005, 07:17 PM
ed2hess's Avatar
ed2hess ed2hess is offline
LawnSite Fanatic
 
Join Date: Nov 2002
Location: Austin Texas 78727
Posts: 11,487
Yes I was wondering if air can get in the pump at the input shaft seal. Mine is leaking at that seal so I am thinking about replacing that seal and crank it back up before changing out the hydro. It doesn't look like there is any way to drain the Walker but I was thinking about pumping out the fluid. Maybe somebody put in the wrong kind of oil before I got the unit.
Reply With Quote
  #9  
Old 05-02-2005, 09:18 PM
fixer67's Avatar
fixer67 fixer67 is offline
LawnSite Silver Member
 
Join Date: Apr 2004
Location: Tryon NC
Posts: 2,161
Quote:
Originally Posted by ed2hess
Yes I was wondering if air can get in the pump at the input shaft seal. Mine is leaking at that seal so I am thinking about replacing that seal and crank it back up before changing out the hydro. It doesn't look like there is any way to drain the Walker but I was thinking about pumping out the fluid. Maybe somebody put in the wrong kind of oil before I got the unit.
Check this out, it will tell all about changing the hydro fluid. Read post number 3.

http://lawnsite.com/showthread.php?s=&threadid=69075
__________________
"DEFECTIVE OWNER/OPERATOR NOT COVERED UNDER WARRANTY"
Reply With Quote
  #10  
Old 05-02-2005, 11:35 PM
Oldtimer Oldtimer is offline
LawnSite Bronze Member
 
Join Date: Apr 2000
Location: Pensacola, Florida
Posts: 1,386
A few years ago B. J. Hydraulics offered rebuilt Walker hydros. The phone number in my computer is 616.623.5736 but the last access date was in 1998.

Oldtimer
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 05:19 PM.

Page generated in 0.11273 seconds with 8 queries