Register free!

The Green Industry's Resource Center



Reply
 
Thread Tools   Display Modes
  #1  
Old 08-30-2005, 02:09 PM
f935boy f935boy is offline
LawnSite Member
 
Join Date: Apr 2005
Location: Md
Posts: 5
F935 problems

I have a 1991 John Deere F935. It has the Yanmar 3 cyl. diesel. It has just quit running for no aparent reason while mowing the other day. I had first thought it to be the filter because it was leaking a little and had not been changed since last year. When I removed it alot of nasty water like stuff ran out of it, which wasn't unusual. It wasn't that. I then thought it was the injectors. I removed them, cleaned and replaced their seals springs and washers. Wasn't that either. It is getting fuel to all cylinders, it is getting plenty of air....it just turns over and over and over. I even tried a little starting fluid...still nothing. I don't know where else to look. Could the mechanical pump be not pumping enough pressure? Is the fuel bad? Are the cylinders not holding enough pressure, (I.E. head gasket or rings)? How do I check the fuel? How do I check the cylinder pressure and what PSI should it be? I have a pressure tester for gas engines but will it work on diesel? Any help is greatly appreciated! Doug
Reply With Quote
  #2  
Old 08-30-2005, 03:41 PM
MBDiagMan MBDiagMan is offline
LawnSite Senior Member
 
Join Date: Nov 2004
Location: NE Texas
Posts: 669
I have lots of experience with engines in general, both diesel and gas, but not with that engine in particular.

That said, a gas engine compression tester will not work. You need one that tops out at about 500PSI or more and with the correct fitting for your injector, or glow plug(if equipped) hole.

Assuming that you bled the system after removing and replacing the injectors, I would suspect timing. What does the engine have for a cam/injection pump mechanism? A belt, a chain, plastic gears.

You really need a manual or someone with lots of experience with that specific engine to know how to check fuel delivery timing to start with. I say to start with, fundamentally you are on the right track in checking compression, but compression typically does not go away all of a sudden.

Best of luck,
Doc
Certified, ASE Master
Reply With Quote
  #3  
Old 08-30-2005, 04:29 PM
f935boy f935boy is offline
LawnSite Member
 
Join Date: Apr 2005
Location: Md
Posts: 5
Thanks! I wasn't thinking timing yet! I'll have to look to see if it has a chain or gears. If a chain, I would agree that the timing could have slipped. It has a ton of hours on it. I believe it is an overhead cam with a chain, so checking it should be easy enough. I think I have the repair manual that would get me the timing info.
Reply With Quote
  #4  
Old 08-30-2005, 04:58 PM
MBDiagMan MBDiagMan is offline
LawnSite Senior Member
 
Join Date: Nov 2004
Location: NE Texas
Posts: 669
It very well could be a belt. Timing chains rarely jump except on the old American cars with Morse chains. Most engines nowdays with chains have double roller chains.

Anyway, with the manual, you should see if there is a timing diagram of some sort. You should be able to turn the crankshaft to a mark and then look at the cam mark to see if it is aligned. It might take two turns of the crankshaft to align the cam.

Checking compression is another way to check cam timing in that if the cam timing is off, so will the compression.

Good luck,
Doc
Reply With Quote
  #5  
Old 08-31-2005, 11:35 AM
f935boy f935boy is offline
LawnSite Member
 
Join Date: Apr 2005
Location: Md
Posts: 5
It all makes sense! While I was tinkering with the fuel filter and injectors, I started to remove the pump just to look at how it works and possibkly clean it out. I removed the 4 bolts that hold in onto the side of the block but I couldn't get it all the way out. It felt like it was hanging up on a shaft or a gear or something? So, I just put it back in place and bolted it down. I turned the tractor over after that and it squirted fuel out of each of the three ports on the top so I thought it was back in the right place. But, did I somehow move a gear or ?????? That would explain the timing. I have not had time to look at it or get into the book to see how to set the timing. I'll let you know. The timing thing also explains why it wouldn't start with starting fluid. right?
Reply With Quote
  #6  
Old 08-31-2005, 09:27 PM
Travis Followell's Avatar
Travis Followell Travis Followell is offline
LawnSite Silver Member
 
Join Date: Sep 2004
Location: KY
Posts: 2,207
Quote:
Originally Posted by f935boy
It all makes sense! While I was tinkering with the fuel filter and injectors, I started to remove the pump just to look at how it works and possibkly clean it out. I removed the 4 bolts that hold in onto the side of the block but I couldn't get it all the way out. It felt like it was hanging up on a shaft or a gear or something? So, I just put it back in place and bolted it down. I turned the tractor over after that and it squirted fuel out of each of the three ports on the top so I thought it was back in the right place. But, did I somehow move a gear or ?????? That would explain the timing. I have not had time to look at it or get into the book to see how to set the timing. I'll let you know. The timing thing also explains why it wouldn't start with starting fluid. right?
Your right. If the engine was out of time it would not start even on starting fluid.
Reply With Quote
  #7  
Old 08-31-2005, 09:56 PM
MBDiagMan MBDiagMan is offline
LawnSite Senior Member
 
Join Date: Nov 2004
Location: NE Texas
Posts: 669
I'm sorry that I'm not familiar with that engine or I could tell you how to time it. You might could move the pump and get it to start, but you also could damage the engine if it were to kick backwards.

I think you should find the correct start of delivery procedure or take it to a tech who has lots of experience with that particular engine.

Good luck,
Doc
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 05:13 AM.

Page generated in 0.08643 seconds with 9 queries