Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 02-04-2007, 11:04 PM
Pepler's Lawncare Pepler's Lawncare is offline
LawnSite Member
 
Join Date: Feb 2007
Location: Dover, New Hampshire
Posts: 20
Ferris Zero turn mower problem

hey was wondering if anyone out there has had any problems with ferris zero turn mowers. I bought one two seasons ago and had to replace both hydro pumps and wheel motors with only 500hrs on machine. Now at the end of this mowing season mower is starting to have the same problem . Can anyone help me? thank you.
Reply With Quote
  #2  
Old 02-05-2007, 07:06 AM
beano beano is offline
LawnSite Senior Member
 
Join Date: Jan 2007
Location: Columbus, OH
Posts: 388
I have a 1500 IS and it will be two years old next month. I had a wheel motor go out on it this past summer and it was covered under warrenty but if it wasnt it would have been a $1500 job. I had about 220 hours on it when it happened.
Reply With Quote
  #3  
Old 02-05-2007, 07:36 AM
2 clowns mowing 2 clowns mowing is offline
LawnSite Senior Member
 
Join Date: Mar 2006
Location: yellow springs ohio
Posts: 566
ferris

my 1500 has had both pumps and wheel motors replace when it goes out of warranty i'm selling it
Reply With Quote
  #4  
Old 02-05-2007, 08:59 AM
Pepler's Lawncare Pepler's Lawncare is offline
LawnSite Member
 
Join Date: Feb 2007
Location: Dover, New Hampshire
Posts: 20
how many hours on your mower? Ive had nothing but problems with it since day one....they had good financeing when i first started so thats what made my decision...now its a toss up between a bobcat or a scag
Reply With Quote
  #5  
Old 02-05-2007, 09:10 AM
upidstay's Avatar
upidstay upidstay is offline
LawnSite Bronze Member
 
Join Date: Oct 2004
Location: CT
Posts: 1,078
You are the 5th person I haver heard say this about Ferri hydro pumps. I'm guessing it is a design flaw or they got a bad batch of pumps. I'd scream long and loud to my dealer.
Reply With Quote
  #6  
Old 02-05-2007, 10:45 AM
DixieFerris DixieFerris is offline
LawnSite Senior Member
 
Join Date: Dec 2005
Location: Upstate NY
Posts: 440
Our dealer said it's only been a problem on the 1500's, and yes it was a design issue in most cases
Reply With Quote
  #7  
Old 02-05-2007, 12:42 PM
LB1234 LB1234 is offline
LawnSite Gold Member
 
Join Date: Dec 2004
Location: Central Jersey
Posts: 3,211
Not sure if this is relevant or not...might be worth taking a look into...


We had a hydro pump go on one of our scags. Brought it back to dealer had it fixed. Not 2-3 weeks later we could tell the pump was starting to go again...was kinda slowing down. Took it back to the dealer...replaced pump a second time. Again, few weeks later starting to have problems. Got fed up with that dealer took it to another one that was recommended by another LCO.

They took the pump apart and found out the problem was the pump but it was going to be useless unless the system was being completely flushed. He showed me all the metal pieces in the fluid.

Perhaps this is your problem?? I know long shot but might be worth a look as to WHY its failing.
Reply With Quote
  #8  
Old 02-05-2007, 02:49 PM
rodfather's Avatar
rodfather rodfather is offline
LawnSite Fanatic
 
Join Date: Aug 2001
Location: Clinton, NJ
Posts: 9,632
Quote:
Originally Posted by 2 clowns mowing View Post
my 1500 has had both pumps and wheel motors replace when it goes out of warranty i'm selling it
Blame the tranny manufacturer, not Ferris.
Reply With Quote
  #9  
Old 02-05-2007, 02:59 PM
Willofalltrades's Avatar
Willofalltrades Willofalltrades is offline
LawnSite Bronze Member
 
Join Date: Dec 2005
Location: Northeast Ohio
Posts: 1,000
Quote:
Originally Posted by DixieFerris View Post
and yes it was a design issue in most cases
Can we blame Ferris now? lol just pullin your chain Rod.
Reply With Quote
  #10  
Old 02-05-2007, 03:18 PM
rodfather's Avatar
rodfather rodfather is offline
LawnSite Fanatic
 
Join Date: Aug 2001
Location: Clinton, NJ
Posts: 9,632
Quote:
Originally Posted by Willofalltrades View Post
Can we blame Ferris now? lol just pullin your chain Rod.
Guess you could blame their design engineers...maybe their Purchasing Department too
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 11:38 AM.

Page generated in 0.07542 seconds with 7 queries