Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 05-30-2007, 06:36 PM
tnt625 tnt625 is offline
LawnSite Member
 
Join Date: May 2007
Location: cleveland ohio
Posts: 1
ferris 36" blade wont start

hello,i have a belt driven ferris 36".today while i was cutting a lawn the blade stopped.i flicked switch on & off a few times,but nothing.took to local repair shop,they suggested replacing switch,which they didnt have of course.i located one & purchased and installed it but still nothing.the blade wont move when its on but if i release handle it stalls out (safety feature)like it is running.i'm looking for any help i could get,
thanks tim
Reply With Quote
  #2  
Old 05-30-2007, 07:55 PM
khouse khouse is offline
LawnSite Bronze Member
 
Join Date: Feb 2001
Location: lee's summit, mo
Posts: 1,479
You need to see if there is battery voltage at the clutch wire when it's engaged. Then we all can go from there.
__________________
"If man can make it - man can break it"
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 01:30 AM.

Page generated in 0.06376 seconds with 7 queries