Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 06-29-2007, 02:27 PM
grass disaster's Avatar
grass disaster grass disaster is offline
LawnSite Silver Member
 
Join Date: Nov 2004
Location: sunny minnesota
Posts: 2,457
charge pump kubota

well the kubota's not runnign so good.

the pto is shutting off when i raise the deck. also deck is slow to raise.

dealer told me, hopfully that's all thats wrong with it is the charge pump which is located on the front of the tranny.

it is driving fine.

can anyone add anything to this. or anyone else have similar problems?
__________________
Lawn Service Lonsdale
Reply With Quote
  #2  
Old 07-02-2007, 03:33 PM
grass disaster's Avatar
grass disaster grass disaster is offline
LawnSite Silver Member
 
Join Date: Nov 2004
Location: sunny minnesota
Posts: 2,457
anyone else having problems with the charge pump?
__________________
Lawn Service Lonsdale
Reply With Quote
  #3  
Old 07-02-2007, 06:59 PM
grass disaster's Avatar
grass disaster grass disaster is offline
LawnSite Silver Member
 
Join Date: Nov 2004
Location: sunny minnesota
Posts: 2,457
i must be the only one that's ever had a problem with this.

i hope it's only the pump that is bad. the pump is only like $100.

if i have to but the whole plate it's like $1600.
__________________
Lawn Service Lonsdale
Reply With Quote
  #4  
Old 07-02-2007, 07:40 PM
DiyDave DiyDave is offline
LawnSite Bronze Member
 
Join Date: Jan 2007
Location: Gambrills, MD
Posts: 1,695
Give it some more time

sooner or later someone with the same problem will read your post. Check back in a couple of days
Reply With Quote
  #5  
Old 07-03-2007, 12:31 PM
grass disaster's Avatar
grass disaster grass disaster is offline
LawnSite Silver Member
 
Join Date: Nov 2004
Location: sunny minnesota
Posts: 2,457
Quote:
Originally Posted by DiyDave View Post
sooner or later someone with the same problem will read your post. Check back in a couple of days
yeah i'm still waiting
__________________
Lawn Service Lonsdale
Reply With Quote
  #6  
Old 07-03-2007, 09:40 PM
grass disaster's Avatar
grass disaster grass disaster is offline
LawnSite Silver Member
 
Join Date: Nov 2004
Location: sunny minnesota
Posts: 2,457
bump.


i would really like to see if anyone knows anything about this before i start tearing stuff apart.


the dealer doesn't want to order me any parts till i take off the charge pump and see if i can see what's wrong.

is it the charge pump? the plate that it butts up against? or a sticky valve or something?
__________________
Lawn Service Lonsdale
Reply With Quote
  #7  
Old 07-05-2007, 03:11 PM
grass disaster's Avatar
grass disaster grass disaster is offline
LawnSite Silver Member
 
Join Date: Nov 2004
Location: sunny minnesota
Posts: 2,457
ahh hello?


does the charge pump drive the hydros?



because it seems to be griving fine.
__________________
Lawn Service Lonsdale
Reply With Quote
  #8  
Old 07-05-2007, 03:21 PM
themowerman themowerman is offline
LawnSite Senior Member
 
Join Date: May 2004
Location: NJ
Posts: 295
Your dealer should be able to plumb in gauges to read the health of your pump. A gauge test will tell if it is the charge pump or not. The only other way is to inspect it.....maybe you sheared the pump pin.....
Reply With Quote
  #9  
Old 07-05-2007, 03:30 PM
razor1's Avatar
razor1 razor1 is offline
LawnSite Bronze Member
 
Join Date: Oct 2006
Location: Maryland
Posts: 1,974
I had a a similar problem with my ZD 21. What year and model Kubota do you have?
Reply With Quote
  #10  
Old 07-05-2007, 04:52 PM
grass disaster's Avatar
grass disaster grass disaster is offline
LawnSite Silver Member
 
Join Date: Nov 2004
Location: sunny minnesota
Posts: 2,457
Quote:
Originally Posted by razor1 View Post
I had a a similar problem with my ZD 21. What year and model Kubota do you have?

zd18 2002 almost 800 hrs.

the zd18 and zd21 use the same hydro system.

what were your symptoms and what was the problem.
__________________
Lawn Service Lonsdale
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 04:58 AM.

Page generated in 0.10870 seconds with 9 queries