Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 09-13-2001, 11:15 PM
crs crs is offline
LawnSite Member
 
Join Date: Feb 2001
Location: Raleigh, N.C.
Posts: 121
redmax eb431

I have a Redmax eb 431 that I use a back up blower. Recently it developed a couple of problems. It surges at full throttle. It will start and run fine for just a couple of seconds and then it drops several hundred rpm and goes back and forth untill you pull the throttle back a little. It will run fine at 3/4 throttle. Also, it leaks fuel out of the vent hole in the cap. It is not a just a dribble. If you slosh the fuel around in the tank, like you would when walking with it on your back, fuel spits out the vent about an inch and a half.

The spark plug, air filter and fuel filter are all new. The carburetor is not adjustable.

The fuel cap has been replaced with two different styles of cap. One works better than the other but they both leak.

Thanks for any input
__________________
Are we having fun yet????
Reply With Quote
  #2  
Old 09-14-2001, 03:11 AM
vipermanz's Avatar
vipermanz vipermanz is offline
LawnSite Bronze Member
 
Join Date: Mar 2001
Location: Birmingham Alabama
Posts: 1,780
im going to say it's your spark arrestor
__________________
<img src="http://img.photobucket.com/albums/v404/vipermanz/Newbanner.jpg" alt="Image hosted by Photobucket.com">
Check Out Weldingweb !!!
Reply With Quote
  #3  
Old 09-14-2001, 04:24 AM
Keith's Avatar
Keith Keith is offline
LawnSite Gold Member
 
Join Date: Dec 1999
Location: Central Florida
Posts: 3,801
I'll agree with vipermanz, check that first. If that fails, replace your fuel lines. Beyond that you are probably looking at a carburetor or a rebuild kit at the least.
Reply With Quote
  #4  
Old 09-14-2001, 04:35 AM
Fish's Avatar
Fish Fish is offline
LawnSite Member
 
Join Date: Feb 2001
Location: Lawrenceburg, KY
Posts: 139
Does your carb have a primer bulb?
Fish
Reply With Quote
  #5  
Old 09-14-2001, 09:42 AM
Cleve Cleve is offline
LawnSite Senior Member
 
Join Date: Dec 2000
Location: Rockmart, GA
Posts: 370
We have two of these. Did have three but someone lifted one off the back of the truck at a customers a year ago.
I'm having some of the same problems with poor performance right now on one. I'm going to check the exhaust as suggested.

Regards the fuel problme, all of ours have had the same problem. And, the dealer has been able to do nothing for them. Replaced the caps more than once. Won't do it all the time but is a problem. I believe Redmax has a fuel cap problem related to how the rubber seal fits against the top of the filler neck on the tank. One of the men at the dealer finally told me that many were doing this and the only real fix had been to be careful to make sure the rubber seal is seated all the way into the cap and to only screw the cap on "softly". Do not attempt to tighten the cap really tight. Seems to help more than anything else.
Cleve.
__________________
Oh, that You would bless me indeed, and enlarge my territory, that Your
hand would be with me and that You would keep me from evil, that I may
not cause pain.
Reply With Quote
  #6  
Old 09-15-2001, 10:54 AM
Jason Pallas Jason Pallas is offline
LawnSite Bronze Member
 
Join Date: Jan 2001
Location: Grosse Pointe. MI
Posts: 1,321
Crs - I have alot of experience with these blowers - we've got about 20-25 of them and that's all we run. Unfortunately, the carbs/fuel systems can be real fickle. If it's the newer style (last 4 years or so) there's no low/high speed idle adjustments on the carbs. This can be a bummer - as once the carb begins to wear, you can't adjust it out and simply have to replace it. I would check your throttle cable system and make sure there's no play there. If that's good, you may want to take the carb apart and clean it. A little piece of dirt stuck in the wrong place could cause a lot of problems. Finally there are two fuel filter systems, one on the pick-up line in the tank and one in the carb (small screen in fuel basin). The filter in the tank can be taken apart and cleaned instead of replacing. Because you said you replaced it, I'd assume that wasn't your problem. - However, these models are infamous for creating fuel pressure vaccums. This sounds like your problem - except, your cap is leaking - so it's unlikely that you've got a vaccum problem. (we've got one unit that runs great but every 20 minutes you need to crack/open the cap to release the vaccum or else the fuel system shuts down. Hopefully some of these hints will send you on the right direction. Good luck
Reply With Quote
  #7  
Old 09-15-2001, 09:14 PM
Fish's Avatar
Fish Fish is offline
LawnSite Member
 
Join Date: Feb 2001
Location: Lawrenceburg, KY
Posts: 139
Does it have a primer bulb?
Reply With Quote
  #8  
Old 12-22-2011, 04:05 PM
robertobradley70 robertobradley70 is offline
LawnSite Member
 
Join Date: Dec 2011
Location: united states
Posts: 1
Hello everyone,

I think I know the problem here but I need a second set of eyes on it. I have a 12 year old Redmax EB431 which has been running fantastically until today (starts on first pull, has good power, no smoke, good compression).Today I started the blower, it ran for about 2 seconds and then just died.

I checked for spark - nothing. The resistance on the secondary coil is about 2k ohms. The resistance on the primary coil (they're physically separate coils on this unit) was around 53m ohms. I took the kill switch out of the picture to make sure that wasn't malfunctioning - still no spark. I took a look at all of the wiring and noticed that the plug wire has a pretty deep gouge in it - deep enough to expose the conductor - but it still conducts electricity. I tried putting the spark plug on a known-good machine (a power washer with a Tecumseh HM80) and it produces a good spark.

At this point, I'm thinking I should replace the secondary coil (if for no other reason to replace the spark plug wire). I couldn't find any coil testing procedures or specifications online and I'd like to get the opinions of some people that see these things every day (or at least in the past have seen them every day). Not only that, but the primary coil is like $75 and the secondary is $50. I don't want to blindly replace parts.

Is there anything else I should try before I replace the secondary? The engine is completely off the blower right now and is fully accessible.

Thanks!!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 12:14 AM.

Page generated in 0.09328 seconds with 7 queries