Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 09-28-2007, 12:28 AM
Nathan 281 Nathan 281 is offline
LawnSite Member
 
Join Date: Apr 2005
Location: MN
Posts: 73
Engine Valve problem

The valve sleeve that holds the valve in the engine block some how slid back and broke the valve spring retainer and bent the push rod. I replaced the bad parts and pushed the sleeve back in and it seemed to be tight in place. How can I be sure I solved the problem? Any one else had this problem?
Reply With Quote
  #2  
Old 09-28-2007, 01:22 AM
khouse khouse is offline
LawnSite Bronze Member
 
Join Date: Feb 2001
Location: lee's summit, mo
Posts: 1,479
I don't know what engine your talking about? But I would bet it got over heated. The sleeve is called a valve guide. You can try installing a new one with lock tite? Or depending on the engine? Peening the block material around the guide? Or you may have to buy an oversized guide and have a machine shop install it? Maybe a short block? You'll have to post your engine numbers???
__________________
"If man can make it - man can break it"
Reply With Quote
  #3  
Old 09-28-2007, 05:29 PM
leeker leeker is offline
LawnSite Member
 
Join Date: Sep 2007
Location: onawa iowa
Posts: 51
this wouln't happen to be on a OHV 14 hp kawaski would it!!! seen this a couple time on this engine.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 08:08 AM.

Page generated in 0.06450 seconds with 7 queries