Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 09-30-2007, 05:15 PM
j455cb j455cb is offline
LawnSite Member
 
Join Date: Sep 2007
Location: Nashville TN
Posts: 9
Hypro D50

I have an older Lesco 300 gallon sprayer with a hypro d50 pump.
I was spraying a yard and lost pressure I checked the tank I still had
around fifty gallons of product that was building alot of foam.
I added de foamer and continued to use with no success. My bypass line
was discharging a frothy liquid at this time I have checked my fittings
and all do not seem to be leaking.
Reply With Quote
  #2  
Old 09-30-2007, 06:35 PM
MowerMedic77's Avatar
MowerMedic77 MowerMedic77 is offline
LawnSite Bronze Member
 
Join Date: Jul 2005
Location: In the shop breaking stuff....
Posts: 1,161
Let me ask you does the unit build pressure with the gun or wand released but when you go to spray and depress the trigger it then losses pressure?
__________________
Remember that the quality of your question directly affects the quality of your answer. Read here to learn more http://www.lawnsite.com/showthread.php?t=144040

Life is an unrelenting comedy. Therein lies the tragedy of it.

How can I soar like an eagle, when I'm surrounded by turkeys?
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 01:34 PM.

Page generated in 0.06736 seconds with 7 queries