Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 04-19-2008, 07:43 PM
exmarkdude exmarkdude is offline
LawnSite Member
 
Join Date: Oct 2002
Location: northwest indiana
Posts: 55
No heat!

Bob, are you out there? Landa 5 pgw 3500 has no heated water. When you pull the trigger sounds like it is putting a bind on the engine. I took the thing that has the spring and piston apart to make sure it was clean and it was. The generator is working. Any ideas?
Reply With Quote
  #2  
Old 04-20-2008, 09:45 AM
FCPWLLC's Avatar
FCPWLLC FCPWLLC is offline
LawnSite Senior Member
 
Join Date: Jan 2007
Location: Lexington, KY
Posts: 347
Quote:
Originally Posted by exmarkdude View Post
Bob, are you out there? Landa 5 pgw 3500 has no heated water. When you pull the trigger sounds like it is putting a bind on the engine. I took the thing that has the spring and piston apart to make sure it was clean and it was. The generator is working. Any ideas?
Call this guy.... http://www.southside-equipment.com/

Russ knows his stuff. Troubleshooting is his game.
__________________
Michael Kreisle
First Choice Power Washing LLC
Lexington, KY 859-983-5955
Awesome Pressure Washing and Great Cleaning Service
Follow us on Facebook.. facebook.com/powerwash
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 05:54 PM.

Page generated in 0.06715 seconds with 7 queries