Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 06-24-2008, 09:59 PM
ljhanson12345 ljhanson12345 is offline
LawnSite Member
 
Join Date: Jan 2008
Location: Huntsville,Al
Posts: 64
chemicals not getting through

hey guys today i tried to run some chemicals through my pressure washer and couldn't get it to run through. all i thought i was suppose to do was hook up the tubing to the pressure washer and put the other end in the chemicals, but it didn't work. there was no suction coming from the tube so is there something im missing.

the pressure washer is a dewalt 13hp 3750 psi and haven't used it much if that helps and i tried to find the manual but couldn't
Reply With Quote
  #2  
Old 06-25-2008, 07:14 AM
FCPWLLC's Avatar
FCPWLLC FCPWLLC is offline
LawnSite Senior Member
 
Join Date: Jan 2007
Location: Lexington, KY
Posts: 347
It will only draw chemicals during low pressure use. You have to use a low pressure tip. Most likely, your machine came with one. The black tip is for low pressure soaping. Hope this helps.
__________________
Michael Kreisle
First Choice Power Washing LLC
Lexington, KY 859-983-5955
Awesome Pressure Washing and Great Cleaning Service
Follow us on Facebook.. facebook.com/powerwash
Reply With Quote
  #3  
Old 06-25-2008, 11:49 PM
CCPC's Avatar
CCPC CCPC is offline
LawnSite Member
 
Join Date: Jun 2008
Location: Jacksonville, FL
Posts: 102
Also, if you were using the the low pressure tip, and still no draw, check the flow arrow on your downstream injector and make sure that it is assembled to flow in the right direction.
__________________
Lance Powell
SoftWash Solutions
904 535 4590
Pressure Washing Houses Jacksonville
Soft Roof Cleaning in Jacksonville
Reply With Quote
  #4  
Old 06-25-2008, 11:59 PM
ljhanson12345 ljhanson12345 is offline
LawnSite Member
 
Join Date: Jan 2008
Location: Huntsville,Al
Posts: 64
alright thanks guys
i think the low pressure tip might do the trick.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 04:03 AM.

Page generated in 0.07404 seconds with 7 queries