Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 08-27-2008, 11:19 PM
David Gretzmier David Gretzmier is offline
LawnSite Gold Member
 
Join Date: Mar 2001
Location: Fayetteville,AR
Posts: 3,654
c-9 cord problems ?

I had used Brite Ideas c-9 cord for 2001-2005 season, then switched to Action Lighting cord in '06 and Holiday Bright Lights cord in '07. I have always had good luck with the Brite Ideas cord, but the action lighting and the Holiday Bright Lights cord have the same problem. It seems the copper strip on the side is too small, and the bulb has trouble making continuous contact. when you bulb without the power on, and then install and plug in, you have to go back and tighten/loosen lots of bulbs to get the "right" contact, and then at least twice a season go back and tighten loosen again on different bulbs. this is rather frustrating, so I am putting it out there to see if anyone has experienced this, and if there is a solution other than replacing the cord. let me know- dave g
__________________
freedom
Reply With Quote
  #2  
Old 08-28-2008, 11:41 AM
hotrod1965 hotrod1965 is offline
Sponsor
 
Join Date: Aug 2007
Location: SE Michigan
Posts: 531
I had some HBL cord last year and never had this issue. But I used all LED retro fit bulbs.
You just had to make sure you screwed them in hand tight or they wouldn't light up.

I wonder if putting some contact greese in the sockets would help? It would be a big pain though.
__________________
The LED Warehouse
Reply With Quote
  #3  
Old 08-28-2008, 05:06 PM
wurkn with amish's Avatar
wurkn with amish wurkn with amish is offline
LawnSite Senior Member
 
Join Date: Apr 2006
Location: in the bathroom
Posts: 663
just keep buying brite ideas stuff!
I have the same thing happen just when were putting the lights up.
haven't had to go back and tighten though.
Contact grease is a good idea
Reply With Quote
  #4  
Old 08-29-2008, 05:02 PM
David Gretzmier David Gretzmier is offline
LawnSite Gold Member
 
Join Date: Mar 2001
Location: Fayetteville,AR
Posts: 3,654
I used the retro fit bulbs on 4 jobs with the same cord, same problem. even when screwed in tight, I have to go back and LOOSEN bulbs to get them to light. just was picky. anybody know where I can get a 5 gallon bucket of dielectric grease?
__________________
freedom
Reply With Quote
  #5  
Old 08-29-2008, 11:01 PM
hotrod1965 hotrod1965 is offline
Sponsor
 
Join Date: Aug 2007
Location: SE Michigan
Posts: 531
Maybe ask a local auto parts place and see if they can hook you up?
__________________
The LED Warehouse
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 06:08 AM.

Page generated in 0.07387 seconds with 7 queries