Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather


Reply
 
Thread Tools Display Modes
  #11  
Old 04-30-2009, 09:41 PM
tglasslawncare's Avatar
tglasslawncare tglasslawncare is offline
LawnSite Senior Member
 
Join Date: Dec 2006
Location: North Huntingdon PA
Posts: 325
My dealer told me to bring my GS back after 10 hours and they would go over everything. Do you think I should ask them to check it over again. I had it there last week and now have 14 hours. Thanks Tom
Reply With Quote
  #12  
Old 05-01-2009, 07:14 PM
lilweeds lilweeds is offline
LawnSite Senior Member
 
Join Date: Feb 2006
Location: Blandon, Pa
Posts: 596
If I were you I'd look it over my self. Did your hand brake lever come loose? Did you have any issues? If you'd like give me a ring 610-802-0744
Reply With Quote
  #13  
Old 05-03-2009, 10:02 PM
tglasslawncare's Avatar
tglasslawncare tglasslawncare is offline
LawnSite Senior Member
 
Join Date: Dec 2006
Location: North Huntingdon PA
Posts: 325
No issues yet. Just under 20 hours. I did take it in at 10 hours like the dealer had asked and I told them you had the hand brake lever issue. He said the mad sure it was tight. The dealer again said bring it in at no more than 10 hours so they could make sure everything was tight and to change the oil. I thought this was routine but never had a brand new machine like this one. I will keep you informed if I have any issues. Thanks for your help and info. I appreciate it.
Reply With Quote
  #14  
Old 05-03-2009, 11:02 PM
KCfireman KCfireman is offline
LawnSite Bronze Member
 
Join Date: Apr 2008
Posts: 1,867
pics pics pics!!!!
Reply With Quote
  #15  
Old 05-13-2009, 10:28 AM
tglasslawncare's Avatar
tglasslawncare tglasslawncare is offline
LawnSite Senior Member
 
Join Date: Dec 2006
Location: North Huntingdon PA
Posts: 325
Bolt came off deck last. The bolt that holds the deck up on the front right of the mower. Just feel off in the middle of mowing. Did not notice right away until some scalping was happening. Could not find it. Took it to the dealer and had it back in 2 hours. A bit of an pain in the you know what during prime mowing season. Dealer was so busy I just pick-ed up the mower and did not get a chance to talk them about the problem. The are a super dealer. I am just upset that it happen with only 28 hours on a practically new machine. I had to call my customer and apologize for scalping marks. Lost a few hours of mowing that day. Trying to not let it bother me too much. Just wanted to let you know.
Reply With Quote
  #16  
Old 05-14-2009, 04:38 PM
lilweeds lilweeds is offline
LawnSite Senior Member
 
Join Date: Feb 2006
Location: Blandon, Pa
Posts: 596
TG,

Toro sent me some replacement hardware that is holding up much better. Unfortunately I didn't save the part numbers, or at least I don't think I did. If I can find them I will get them to you to give to your dealer. Maybe Toro Company can chime in with the numbers? They also gave me an extra to replace the nut for the brake handle. It hasn't come loose since.

Rich
Reply With Quote
  #17  
Old 05-14-2009, 09:41 PM
tglasslawncare's Avatar
tglasslawncare tglasslawncare is offline
LawnSite Senior Member
 
Join Date: Dec 2006
Location: North Huntingdon PA
Posts: 325
Thanks I appreciate the info
Reply With Quote
  #18  
Old 06-15-2009, 08:39 PM
lilweeds lilweeds is offline
LawnSite Senior Member
 
Join Date: Feb 2006
Location: Blandon, Pa
Posts: 596
Well I must commend Toro again. This past Saturday I picked up my second Grandstand. They made a few improvements for the later serial number units. Fixing all the hardware issues and a few things I didn't expect! The plastic belt covers are stout and will not go anywhere. The longer brake handle is nice. The only thing I noticed that maybe should be fitted to all models is the hose guards on the frame to keep the Hydro hoses from rubbing the lift arms.

Toro is there a way to fit the new covers to the old units. The knobs keep the metal ones on, but the rattle alot and don't stay centered.

Rich

PS Pics will follow soon I promise.
Reply With Quote
  #19  
Old 06-21-2009, 11:11 AM
robertsturf's Avatar
robertsturf robertsturf is offline
LawnSite Bronze Member
 
Join Date: Feb 2004
Location: Independence,Mo
Posts: 1,387
We are having not stop problems with the throttle cable on one of our units. They have fixed the pulley covers with the new hardware. We are still having the same issues with the parking brakes!! I wish they had demo'd this more without having us doing it for them. Let a LCO use one for 2-3 mo's and then get some real feed-back. All-in-all still a great mower just aggrevated these problems are still occuring!! BTW we decided to take off the muffler guard on the one that was having the throttle cable issue, we felt the heat was being held in around the cable causing the failure. 2 cables so far and needing a 3rd. Around 100hrs on both mowers.
Reply With Quote
  #20  
Old 06-21-2009, 09:19 PM
lilweeds lilweeds is offline
LawnSite Senior Member
 
Join Date: Feb 2006
Location: Blandon, Pa
Posts: 596
I have 100 on one no issues with the cable yet.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 12:13 PM.

Page generated in 0.10065 seconds with 7 queries