Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 06-06-2009, 10:43 PM
THC THC is offline
LawnSite Silver Member
 
Join Date: Oct 2008
Posts: 2,020
Brake light problem

2001 cavalier.

My rear brake lights - not working
My rear turn signals- not working
Rear reverse lights- working
Rear 3rd brake light in window- working
Trunk opening- working

It doesn't look like the bulbs or the fuses. Any idea? I've googled some strange solutions like spraying WD40 in the hazard light switch and toggling it back and forth a bunch of times, replacing Pressure switch at brake pedal?
Reply With Quote
  #2  
Old 06-06-2009, 11:10 PM
THC THC is offline
LawnSite Silver Member
 
Join Date: Oct 2008
Posts: 2,020
The turn signals on the front blink VERY fast btw.
Reply With Quote
  #3  
Old 06-06-2009, 11:21 PM
Restrorob's Avatar
Restrorob Restrorob is offline
LawnSite Fanatic
 
Join Date: Apr 2005
Location: Show'n my truck off !
Posts: 10,260
Sounds like you have a ground fault somewhere, Are you getting power to the rear bulb sockets using a test light or multimeter ?

Then the ground at the rear socket can be tested with either as well....

I would throw the other two suggestions out the window for now.
__________________
Quote:
Originally Posted by piston slapper View Post
You never learn anything until you admit you don't know it all...

"Why go out preserved when you can go out beat up, worn out, sliding in sideways screaming, Holy Sh!t What A Ride" !!!
Reply With Quote
  #4  
Old 06-06-2009, 11:44 PM
THC THC is offline
LawnSite Silver Member
 
Join Date: Oct 2008
Posts: 2,020
Yeah there's power, the tale lights work. They have those bulbs with two filaments in them, I guess the 2nd filament lights up when you depress the brake.

I actually googled *fast blinkers, and got a nugget of info that I've never heard of before. It said that fast blinking is a warning sign that your one of the bulbs is burning out or burnt out. So if you left is fast one of the bulbs on the left is fubared.. I have fast blinking on both sides. I guess it's possible that both bulbs burned out at separate times and no one noticed. I never drive this car myself, I only drive trucks.

Tomorrow I'll try replacing both bulbs and hope it's as simple as that. It's amazing how many people are on the net search for light problems with cavaliers.
Reply With Quote
  #5  
Old 06-08-2009, 12:26 PM
davido30093 davido30093 is offline
LawnSite Member
 
Join Date: Jul 2008
Location: Jasper, GA
Posts: 13
Possible bad multi-function switch (turn signal switch)

If you replace/verify that ALL of the bulbs are good, you may have a bad multifunction switch.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 05:06 AM.

Page generated in 0.08053 seconds with 7 queries