Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 06-10-2009, 10:15 PM
ubirajara83's Avatar
ubirajara83 ubirajara83 is offline
LawnSite Member
 
Join Date: Dec 2006
Location: West Palm Beach, FL
Posts: 172
Scag 61 losing power?

Hello can any one help me. My scag is back firing like crazy when blades are off and then when blades are on if feels like its going to shut off but it doesnt. Could it be my carburetor? Its not the coils bc I checked each by pulling one at a time and then starting the mower. Anyone have any clue.
__________________
97 Dodger Ram1500
2007 7x16 enclosed trailer
2004 6x12 open trailer
42" Hustler
48" Yazoo Kees
3 echo trimmer
3 echo edger
3 echo blower
2 stihl chainsaw
3 echo double sided hedge trimmer
1 Husqvrna single sided hedge trimmer
Hand tools etc..
Reply With Quote
  #2  
Old 06-10-2009, 10:27 PM
SILVERSTREAK INC's Avatar
SILVERSTREAK INC SILVERSTREAK INC is offline
LawnSite Senior Member
 
Join Date: Jan 2007
Location: Horsham, Pa
Posts: 295
first thing to check is your fuel filter, its clogged with grass most likely, if you can blow through it easily then its good
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 02:19 AM.

Page generated in 0.06139 seconds with 7 queries