search sponsored by:
Advanced Search

The Green Industry's Resource Center

Old 04-19-2002, 12:59 AM
Turfcutters Plus Turfcutters Plus is offline
LawnSite Senior Member
Join Date: Apr 2002
Location: Illinois
Posts: 391
Toro Z-master starting problem,help!

has anyone ever had a short in fuse holder wires causing battery to not connect?Have to jump start mower.Was in shop last year for same problem.Fuses are good ,and clean.Any help would be appriciated.I hate to get out my gravely promaster 100!
Reply With Quote
Old 04-20-2002, 03:39 AM
bwiesner bwiesner is offline
LawnSite Member
Join Date: Apr 2002
Location: Portland Tn.
Posts: 16
When you say jump start what are you jumping to start it? Just hooking booster cables to the battery of by-passing the solenoid? Later Butch
Reply With Quote
Old 05-02-2002, 12:22 AM
LawnSite Member
Join Date: Jan 2002
Posts: 19

Let us know the type of engine on your mower, and a general idea of what the shot did to get you going. Give us a little more info and we'll see if we can keep you from digging up that old dino mower of yours.
Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Layout Style:

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 07:34 AM.

Page generated in 0.06626 seconds with 8 queries