Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 08-23-2009, 11:54 PM
creeksidelc44 creeksidelc44 is offline
LawnSite Member
 
Join Date: Jul 2009
Location: jefferson, ga
Posts: 2
Mechanic says Stihl fs 80 suddenly lost compression???

I took my Stihl fs 80 weedeater into the shop about 2 weeks ago. The trimmer is about 4 years old. It would not run consistently. It wanted to die at half speed and other times die randomly. Mechanic told me he would check it out and let me know whats up. He put a new coil in and said it was fixed.....I pick it up and head to the first yard and it was just as bad as before. I ask him could it be a carb or compression problem? He said comp was excellent and it needed a new carb. He installed the new carb and called me this week to pick it up. When I get there he tells me it isn't running right still and has low compression. He apparently forgot he told me the comp was good 2 weeks ago. He studdered and fumbled with his words and finally told me the compression had fallen from 145 to 105 in the last 2 weeks while sitting in the shop....Is this possible for compression to fall this suddenly without even being used, or is he ripping me off? I have already had previos problems with him..
Thanks for any help
Reply With Quote
  #2  
Old 08-23-2009, 11:58 PM
ricky86 ricky86 is offline
LawnSite Bronze Member
 
Join Date: Aug 2008
Location: Monmouth Cty N.J.
Posts: 1,175
He's an idiot. He has no right to be repairing equipment and charging people. Get that thing out of his shop and find a mechanic.
Reply With Quote
  #3  
Old 08-24-2009, 11:28 PM
mowerknower mowerknower is offline
LawnSite Senior Member
 
Join Date: Aug 2008
Location: obamanation
Posts: 766
Buy a tester and check it yourself. He could have a bad tester, happened to me once. Its a little embarassing. Although sounds a little shady anyways, I would take it to another dealer and have it checked out again.
Reply With Quote
  #4  
Old 08-25-2009, 12:46 AM
topsites topsites is offline
LawnSite Fanatic
 
Join Date: Mar 2005
Location: Richmond Virginia
Posts: 21,677
Yeah, where have I heard this story before?

I don't think it's the compression, but the guy doesn't want to fix it right.
I've got an FS-85r that supposedly lost all compression, too...
It sat for 6 years until I got it running again.
That's not a typo, for 6 years it sat not running...
Yes it runs good now.

What I learned?
Could be the coil GAP isn't set properly now...
Could be the carb needs 'adjusting'

Has it got a new air filter and spark plug?
How about the fuel filter inside the tank?
The fuel lines, what's their condition?

There's more...
But you're probably just going to have to play with it, but whatever you do, don't throw it away!
Even if you never get it running again, keep it for parts.

Last edited by topsites; 08-25-2009 at 12:50 AM.
Reply With Quote
  #5  
Old 08-26-2009, 12:26 AM
creeksidelc44 creeksidelc44 is offline
LawnSite Member
 
Join Date: Jul 2009
Location: jefferson, ga
Posts: 2
yea, all that other stuff is right. I've checked and he has too. It does surely have about 105 on the compression now, but what I want to know is could it have actually fallen from 145 to 105 by just sitting in the shop 2 weeks? I would think not....
Reply With Quote
  #6  
Old 08-26-2009, 02:51 AM
topsites topsites is offline
LawnSite Fanatic
 
Join Date: Mar 2005
Location: Richmond Virginia
Posts: 21,677
Quote:
Originally Posted by creeksidelc44 View Post
yea, all that other stuff is right. I've checked and he has too. It does surely have about 105 on the compression now, but what I want to know is could it have actually fallen from 145 to 105 by just sitting in the shop 2 weeks? I would think not....
No, but those compression testers aren't perfect either, I mean...
There's these adapters you have to use, and a rubber grommet, and set it all up and screw it into the spark plug hole...
You want to get it nice and tight but remember if you go too far the piston will HIT
So then you still have to get an airtight seal capable of withstanding the pressure...

145 psi is a LOT of pressure, matter of fact so is 105...
It's tricky, the seal has to be really tight and perfectly good and airtight all around.

So it's quite possible, just as an example, that the mechanic checking it didn't get
a really firm, tight and perfectly good seal, and that a little air past 105 leaked out...

Just for example, but 105 is good enough, the basic rule of thumb says that over 100 is good,
why because we can't always get that perfect seal either.

Now if it's your only trimmer, you may well have to buy another for the time being, it's just that situation...
Fool with it when you have some time, but it gets to a point that from a labor standpoint it's going to cost
more to troubleshoot every last possibility than it would to just buy another.
Not that I want to agree with the dealer or the mechanic LOL, but it happens to be the truth.
Reply With Quote
  #7  
Old 08-26-2009, 10:40 PM
mowerknower mowerknower is offline
LawnSite Senior Member
 
Join Date: Aug 2008
Location: obamanation
Posts: 766
Actually, if the unit sat for a while it could loose compression. The rings could have stuck in. Or he could have got a high reading the first time due to excessive carbon build up. Its a long shot but it is possible.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 10:48 AM.

Page generated in 0.09233 seconds with 7 queries