Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 10-14-2009, 05:23 PM
MCSSPimpin MCSSPimpin is offline
LawnSite Member
 
Join Date: Sep 2009
Location: Grand Ridge, FL
Posts: 10
Kawasaki mule engine problem

Hey, I've been tasked with fixing a mule 3010 4x4 KAF620E 617cc v-twin OHV (will not start).
After checking the basics, I found that:
The engine is overfull according to the dipstick and the oil looks and smells like it has water or gas in it;
The spark plugs are fouled;
The air filter is soaked with oil/gas/water or whatever it is (mud colored);
There is gunk around one of the valve covers.

What would be the best order of action to take in fixing this problem?
Thanks for any imput!
Reply With Quote
  #2  
Old 10-14-2009, 07:03 PM
Two Seasons's Avatar
Two Seasons Two Seasons is offline
LawnSite Senior Member
 
Join Date: Jun 2007
Location: Waukesha, WI
Posts: 791
Float seat stuck open is my guess. Carb needs to be removed and/or cleaned/rebuilt.
__________________
We like orange machines!
Reply With Quote
  #3  
Old 01-20-2012, 09:32 PM
mechanic kevin mechanic kevin is offline
LawnSite Member
 
Join Date: Jan 2012
Location: Palata, FL
Posts: 12
I am working on one now, same model. Do you know if it is a 6 or 12 volt fuel pump ? Thanks
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 03:47 PM.

Page generated in 0.05840 seconds with 7 queries