Register free!

The Green Industry's Resource Center



Reply
 
Thread Tools   Display Modes
  #1  
Old 04-15-2010, 04:50 PM
lawnandl's Avatar
lawnandl lawnandl is offline
LawnSite Member
 
Join Date: May 2004
Location: new jersey
Posts: 78
walker mower battery problems

I have a 1995 walker mower model mtghs, with a 20hp kohler engine. The problem is that the battery keeps dying. Even if i replace the battery, 3 days or so go by and another dead battery. i've looked at the wiring and everything seems to be in tact. The battery dies when just sitting there not even turned on, like overnight. it's killing me to fix this myself and not drop it off and wait a week or two to get it back. any ideas? thanks......and time to go charge it again!...

Last edited by lawnandl; 04-15-2010 at 04:59 PM.
Reply With Quote
  #2  
Old 04-15-2010, 07:40 PM
Restrorob's Avatar
Restrorob Restrorob is offline
LawnSite Fanatic
 
Join Date: Apr 2005
Location: Show'n my truck off !
Posts: 10,761
You could have two issues here but start with the no charge issue first which could solve the battery drain issue.

You have a three wire plug connector on the voltage regulator mounted to the flywheel cover, Use a automotive test light or multimeter and check for battery voltage on the center wire in this plug connector.

If you have battery voltage un-plug this connector, Now put the test leads from a multimeter set on AC volts across the two outer wires in this plug connector. Start the engine and give it full throttle, The reading should be anything above 28 volts AC.

If you get a reading of more than 28 volts AC replace the voltage regulator, Then start the engine and test across the battery post. It should read 13 to 14.5 DC volts.

If you now have the charging system functioning remove the positive battery cable and put your multimeter test leads between the cable and battery post, You should get no reading on the meter with everything off on the unit.

If you do get a reading you have a short in the electrical system, Start by checking the wire harness for any bare wires.

That should keep you busy for a little bit......

Good Luck
__________________
Quote:
Originally Posted by piston slapper View Post
You never learn anything until you admit you don't know it all...
Quote:
Originally Posted by MannsLawnService View Post
some times the man in my mirror isn't so smart...
"Why go out preserved when you can go out beat up, worn out, sliding in sideways screaming, Holy Sh!t What A Ride" !!!
Reply With Quote
  #3  
Old 04-15-2010, 09:30 PM
fixer67's Avatar
fixer67 fixer67 is offline
LawnSite Silver Member
 
Join Date: Apr 2004
Location: Tryon NC
Posts: 2,161
On a Walker there is a metal cover over the V/R. The back wheel fork can get bent letting the wheel hit the metal cover and pushing it into the V/R damaging the connector. I have seen dirt build up behind the cover and short the V/R as well. Remove the V/R and clean it. Check for damage to the casing. Clean the mouning holes as well. Make sure the V/R grounding strap is OK
__________________
"DEFECTIVE OWNER/OPERATOR NOT COVERED UNDER WARRANTY"

Last edited by fixer67; 04-15-2010 at 09:33 PM. Reason: to add info
Reply With Quote
  #4  
Old 04-24-2010, 05:53 PM
lawnandl's Avatar
lawnandl lawnandl is offline
LawnSite Member
 
Join Date: May 2004
Location: new jersey
Posts: 78
thanks for the input... there was no damage to the V/R. i took off the plate and checked the wires and they are fine. the three wire plug connector on the voltage regulator is also fine. What if the circuit breaker was bad or the relays, or safety switches? what would happen then?
Reply With Quote
  #5  
Old 04-24-2010, 07:36 PM
fixer67's Avatar
fixer67 fixer67 is offline
LawnSite Silver Member
 
Join Date: Apr 2004
Location: Tryon NC
Posts: 2,161
There is no relay or safety switches on that circuit. Give me the model year and serial number and I will check about that breaker. With the key switch in the RUN position you should get 12 volts DC from the battery on the middle terminal and the frame at the V/R. With the engine running you should get any where from 28 to 36 volts AC from the two outer terminals at the V/R. Check and see what you at the V/R and let us know. Give me the model and year and serial number and I will get you some wiring info. I just thought of something. Check the starter. There is a purple wire at the starter on most models that runs to the V/R check the wire. Had one a few weeks back that a stick broke that wire and it stopped charging.
__________________
"DEFECTIVE OWNER/OPERATOR NOT COVERED UNDER WARRANTY"
Reply With Quote
  #6  
Old 04-26-2010, 12:03 PM
VegetiveSteam VegetiveSteam is offline
LawnSite Senior Member
 
Join Date: May 2004
Location: St Louis, MO
Posts: 297
All of the previous posts have given you some great info but unless I've overlooked it in their posts they all forgot one very important thing to check that I see quite often. Make sure the voltage regualator is grounded. The two screws that mount the voltage regulator to the engine are different colors. Looking at the goldish colored one there is either a green wire or a thin strap on that screw. Make sure that is connected to ground. Another way to check if the regulator is properly grounded is to use your test light. If you do indeed have battery voltage to the center (violet) wire in the regulator plug with the key on proceed as follows. Connect your test light to the negative terminal of the battery. With the key turned on (engine doesn't need to be running) touch the metal case of the voltage regulator with your test light. Your light should NOT light. If it does then that tells you that the regulator is not grounded. Ground it and everything should work just fine.
Reply With Quote
  #7  
Old 04-26-2010, 04:10 PM
lawnandl's Avatar
lawnandl lawnandl is offline
LawnSite Member
 
Join Date: May 2004
Location: new jersey
Posts: 78
i did the test VegetiveSteam had said and the regulator is properly grounded. Is the circuit breaker supposed to light up with the test light on both posts when the key is off? because this is the case...also the starter wires are fine..i am now going to check test leads between the cable and battery post like restrorob suggested.
Reply With Quote
  #8  
Old 05-17-2010, 10:44 AM
huntdeer huntdeer is offline
LawnSite Member
 
Join Date: May 2010
Posts: 3
what type battery does it take for a 16.5 diesel md? i recently purchased this mower and now it will not start. any suggestions would be greatly appreciated.
Reply With Quote
  #9  
Old 06-01-2010, 12:24 PM
alanauer alanauer is offline
LawnSite Member
 
Join Date: May 2010
Location: WEST OF TORONTO
Posts: 238
Sorry, hunt, don't know what an md is, but with a diesel, all the battery can do is spin it fast enough to ignite, and if that doesn't happen, it's usually a fuel problem.
Reply With Quote
  #10  
Old 06-01-2010, 02:59 PM
Ruben Rocha Ruben Rocha is offline
LawnSite Senior Member
 
Join Date: Jul 2004
Location: Lutz,Florida
Posts: 577
Okay back to restrorob's suggestion did you check the voltage to see if it is charging at all.
What was the voltage?
If the voltage is correct for charging the battery and the battery is not defective.
Then his next suggestion was to check for a short.
Which means in the test the short is draining the battery.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 03:59 PM.

Page generated in 0.09517 seconds with 7 queries