Register free!

The Green Industry's Resource Center



Closed Thread
 
Thread Tools   Display Modes
  #31  
Old 08-16-2011, 02:37 AM
MJB's Avatar
MJB MJB is offline
LawnSite Silver Member
 
Join Date: Aug 2000
Location: Wa
Posts: 2,868
Quote:
Originally Posted by smithfabinc View Post
give me a call anytime....lol. Id love to tell you about how this problem is going.......... 704 640 9553. I got the run-around at the factory again today, same as always. Its a real shame that they handle their business like that.
Have you tried calling the rep for your area? I don't know if it would help but that is usually what I have done with different companies to get the best results especially if the dealer isn't helping. The reps are listed on their website. I've had good luck so far with my Outlaw which was the same as Liberty's but I don't have employees and sometimes that can make a difference too.
__________________
MJB

2013 Exmark Pioneer S 60" Ultracut (Review with pics) http://www.lawnsite.com/showthread.php?t=410996

2010 Badboy Outlaw 6100 31 KAWI

2008 Exmark Lazer Z AS 60" U/C 28 Kawi

2000 Exmark Lazer Z 60" L/C Kawi 4100 + hrs strong
  #32  
Old 08-16-2011, 10:15 AM
smithfabinc smithfabinc is offline
LawnSite Member
 
Join Date: Aug 2011
Location: Salisbury NC
Posts: 177
Quote:
Originally Posted by MJB View Post
Have you tried calling the rep for your area? I don't know if it would help but that is usually what I have done with different companies to get the best results especially if the dealer isn't helping. The reps are listed on their website. I've had good luck so far with my Outlaw which was the same as Liberty's but I don't have employees and sometimes that can make a difference too.
Tried that already, The sales rep for this area lives in Arkansas, so Im not sure how that works... He said it would be after labor day before he could come and take a look at it, and wouldnt give me an exact date, so who knows with stuff going on like this. Im running a worn out back up mower till they solve the problem with this $11,000 bad boy sitting in the shop.
  #33  
Old 08-16-2011, 10:58 AM
MJB's Avatar
MJB MJB is offline
LawnSite Silver Member
 
Join Date: Aug 2000
Location: Wa
Posts: 2,868
Quote:
Originally Posted by smithfabinc View Post
We bought a bad boy aos 28cat diesel three weeks ago and have had nothing but problems. Park brake wont hold, water temp guage doesnt work, idler pulley for pump belt severely misaligned so its eating belts, cut quality SUCKS in tall fescue, and throws major clumps unless its "drought" dry, and now the fuel guage leaks diesel fuel all over the tank and tire. Took it back to the dealership, and they were going to grind inside the drum of the park brake to "roughen it up"....lol...&*%$#@! idiots! Then called Bad boy factory only to get the run around and be told that a "sales rep" would be out after labor day to look at it.. Thats 4 weeks from now! Wondering if anyone ealse is having issue like this? so far, all I can say is I cant depend on the mower, the factory, or the pathetic dealer i bought it from.
Did the dealer fix the fuel leak? I would takle pics of each problem and send them to the rep to get the parts needed to make repairs. Don't know how to fix the misaligned pump belt. Post pictures of it if time allows. As far as the clumping goes get the highest lift blades you can find. I assume you are using the notched hi lifts, I went to a Scag hi lift on mine but it has a 61" deck. There are some guys that used Exmark blades on the 60" deck but you have to get the right size center hole.

Post pictures on here and send them to the BB rep. Maybe someone will step up to the plate. BB knows we can not afford the downtime , did you ask for a loaner from your dealer? I doubt you would get 1 but it Never hurts to ask, Hustler is the only dealer I've ever had to ask for a loaner for and they were good about that and they were 100 miles away from me.
__________________
MJB

2013 Exmark Pioneer S 60" Ultracut (Review with pics) http://www.lawnsite.com/showthread.php?t=410996

2010 Badboy Outlaw 6100 31 KAWI

2008 Exmark Lazer Z AS 60" U/C 28 Kawi

2000 Exmark Lazer Z 60" L/C Kawi 4100 + hrs strong
  #34  
Old 08-16-2011, 11:05 AM
hammmerhead's Avatar
hammmerhead hammmerhead is offline
LawnSite Senior Member
 
Join Date: Sep 2010
Location: ozarks
Posts: 266
How about emailing a link from this thread to BadBoy? I bet that gets all the replacement parts coming faster. Might as well reveal the lackluster dealer you bought them from so you can save others from the extended down time they have allowed.
  #35  
Old 08-16-2011, 12:57 PM
TheOctagon TheOctagon is offline
LawnSite Senior Member
 
Join Date: Feb 2008
Location: South Central Minnesota
Posts: 427
Quote:
Originally Posted by smithfabinc View Post
We bought a bad boy aos 28cat diesel three weeks ago and have had nothing but problems. Park brake wont hold, water temp guage doesnt work, idler pulley for pump belt severely misaligned so its eating belts, cut quality SUCKS in tall fescue, and throws major clumps unless its "drought" dry, and now the fuel guage leaks diesel fuel all over the tank and tire. Took it back to the dealership, and they were going to grind inside the drum of the park brake to "roughen it up"....lol...&*%$#@! idiots! Then called Bad boy factory only to get the run around and be told that a "sales rep" would be out after labor day to look at it.. Thats 4 weeks from now! Wondering if anyone ealse is having issue like this? so far, all I can say is I cant depend on the mower, the factory, or the pathetic dealer i bought it from.
Sounds to me more like a bad dealer experience than being all Badboy's fault. I have warrantied temp gauges with no problems so i dont know why your dealer isnt doing the same. I havent had a belt alignment issue though so cant comment on that but i would sure say that should also be an easy fix for the dealer. As for parking brakes i have always had an issue with getting them to hold as well as my scags. Havent taken the time to see what major difference there is in them yet. As for the clumping and poor cut i recommend getting gator g6 blades and leveling your deck properly. They are touchy decks but when set up correctly they really can perform nicely. The new outlaw deck is worlds beyond the standard 60" and i have never had a single complaint about the cut from them. I am sorry about your poor experience but as i said it could pretty much all be fixed in a days time by your dealer if he wanted to.
  #36  
Old 08-16-2011, 01:06 PM
GravyTrain's Avatar
GravyTrain GravyTrain is offline
LawnSite Senior Member
 
Join Date: Aug 2006
Location: Sherwood, AR
Posts: 375
Quote:
Originally Posted by PROCUT1 View Post
Remember, they didnt, on purpose, put a machine out the door with issues. So give them the benefit of the doubt and see if they make right. If they do, then hopefully you tell everyone about your good experience.
I've got to remember this quote. I often immediately point fingers at the manufacturer and question why they would ever put out a faulty product. I can't imagine that any business (respectable or not) would intentionally provide the consumer with an completely jacked up piece of equipment.
__________________
I'm a Stihl handheld guy, with Toro push mowers, no brand loyalty on bigger mowers. You couldn't pay me to own a Ford or Dodge.

My business provides quality lawn care, but more than that, we offer even higher customer service.
  #37  
Old 08-16-2011, 02:53 PM
MOHUSTLER's Avatar
MOHUSTLER MOHUSTLER is offline
LawnSite Bronze Member
 
Join Date: Nov 2007
Location: Missouri
Posts: 1,376
Sorry to hear of your bad experiences, Keep us updated on how they take care of the problem. Its good to hear from actuaul owners on how they stand behind thier product.
  #38  
Old 08-16-2011, 04:38 PM
smithfabinc smithfabinc is offline
LawnSite Member
 
Join Date: Aug 2011
Location: Salisbury NC
Posts: 177
Quote:
Originally Posted by TheOctagon View Post
Sounds to me more like a bad dealer experience than being all Badboy's fault. I have warrantied temp gauges with no problems so i dont know why your dealer isnt doing the same. I havent had a belt alignment issue though so cant comment on that but i would sure say that should also be an easy fix for the dealer. As for parking brakes i have always had an issue with getting them to hold as well as my scags. Havent taken the time to see what major difference there is in them yet. As for the clumping and poor cut i recommend getting gator g6 blades and leveling your deck properly. They are touchy decks but when set up correctly they really can perform nicely. The new outlaw deck is worlds beyond the standard 60" and i have never had a single complaint about the cut from them. I am sorry about your poor experience but as i said it could pretty much all be fixed in a days time by your dealer if he wanted to.
We tried the gator G6 baldes, a set of "wave" type blades, and a set of high and low lift standard blades. Nothing helped the cut except to wait until after lunch time when the grass is bone dry to cut, but as a commercial cutter, that kills half the day. Ive heard the new outlaw decks are better, but wont fit the aos diesel line. It really says alot about the dealer, and I hope that all the crap Im going through helps someone in the future make a better choice. Im not saying its all bad boys fault, but dealers are a direct representative of a company, and it should have been handled there. Being as dis-pleased as we are with this mower, we asked for a refund, but were told he would only give us a used trade in value for the mower thats only three weeks old. All a rep from the company could tell us is we could either take the mower to a different dealer thats an hour away, or sell it on craigslist. Its just not right to have to loose that much money on a new mower because of poor dealer support, or have to depend on another dealer that is an hour away.
  #39  
Old 08-16-2011, 04:49 PM
smithfabinc smithfabinc is offline
LawnSite Member
 
Join Date: Aug 2011
Location: Salisbury NC
Posts: 177
Quote:
Originally Posted by MOHUSTLER View Post
Sorry to hear of your bad experiences, Keep us updated on how they take care of the problem. Its good to hear from actuaul owners on how they stand behind thier product.
Its pretty sad, because this morning I got a call from a factory rep that basically said He didnt believe anything that I was saying, and that I shouldnt be posting stuff like that on here. I POSTED the FACTS! I didnt get hardly any response from anybody till I posted on here, and now all of the sudden, they are wanting to jump right in and start fixing the problem. The problem with that is that the next closest dealer is a little over an hour from here, and although they did offer to meet me at the new dealer to get all the stuff fixed, thats a long way to go just to get service work done or for anything ealse that goes wrong with this mower. They also offered to send parts factory direct, but then I have to wait on the parts and do the work myself, and for $11K, it ought to have a better dealer support system than that. Im surprised that they dont have more dealers around, but Im kinda starting to see why.
  #40  
Old 08-16-2011, 05:07 PM
smithfabinc smithfabinc is offline
LawnSite Member
 
Join Date: Aug 2011
Location: Salisbury NC
Posts: 177
Quote:
Originally Posted by MJB View Post
Did the dealer fix the fuel leak? I would takle pics of each problem and send them to the rep to get the parts needed to make repairs. Don't know how to fix the misaligned pump belt. Post pictures of it if time allows. As far as the clumping goes get the highest lift blades you can find. I assume you are using the notched hi lifts, I went to a Scag hi lift on mine but it has a 61" deck. There are some guys that used Exmark blades on the 60" deck but you have to get the right size center hole.

Post pictures on here and send them to the BB rep. Maybe someone will step up to the plate. BB knows we can not afford the downtime , did you ask for a loaner from your dealer? I doubt you would get 1 but it Never hurts to ask, Hustler is the only dealer I've ever had to ask for a loaner for and they were good about that and they were 100 miles away from me.
Ive got the highest lift set of blades I could find, They are the new hustler VX4 blades that are 3" wide and have a massive amount of sail on them. I think the issuse with this deck are the baffles. When you are cutting sticky, well taken care of fescue, the baffle closest to the discharge opening kicks the flow to the back of the deck, instead of out the opening. The dealer wont fix anything, all he wanted to do is look at it, and then go make a "phone call". At this point, with the issues we are having, and not having another dealer within a reasonable distance, we just want a refund so we can buy another hustler. I had only 1 problem with our hustler diesel, and they gave us a loaner mower without even having to ask for one. And, the problem was solved without even questioning us, or being told "you are the only one with a problem".... which I have found lots of guys on here that have had the same issues and alot more with this particular model. This mower was advertised by the dealer as the most bang for your buck, but with all the issues, Ive spent WAY more on trips to the dealer and downtime than I would if Id have bought a big name diesel mower to begin with.
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 01:20 PM.

Page generated in 0.12434 seconds with 7 queries