Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 10-18-2011, 08:54 PM
dreamscapes29 dreamscapes29 is offline
LawnSite Member
 
Join Date: Oct 2011
Location: Pell City, Al
Posts: 3
Starting Problem with Kubota ZG20

I have a problem running my Kubota ZG20. I have already spent $500 at two different Kubota dealerships and the problem is still not fixed! Here's what is happening... The engine will try to crank, but the plugs are only getting a spark sometimes. I have tested them and know this to be true. Also, when the mower does crank, as soon as I pull the parking brake up, the mower shuts off. When I try to crank again, the spark plugs will not spark. What do you think is happening?

The battery is new. The dealership replaced the seat safety switch and the relay switch. (at least they said they did).

Why is the spark plug only getting a spark sometimes?
Why will the mower turn off when I pull the parking brake up?
Reply With Quote
  #2  
Old 10-18-2011, 10:56 PM
TNGrassCutter's Avatar
TNGrassCutter TNGrassCutter is offline
LawnSite Bronze Member
 
Join Date: Apr 2010
Location: Tennessee
Posts: 1,282
My zg23 did the same thing with the spark issue. It was a relay switch under the seat behind the battery they had to replace. There are a bunch if those relays so randomly changing one is probably not going to work. The dealer just had to sit down and start testing wires on mine.
Posted via Mobile Device
Reply With Quote
Reply

Tags
brake safety switch , kubota , spark plug problem , starting problem , zg20

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 07:52 AM.

Page generated in 0.06258 seconds with 7 queries