Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 10-23-2011, 08:52 AM
485DEERE 485DEERE is offline
LawnSite Member
 
Join Date: Oct 2011
Location: INDIANA
Posts: 13
New member seeking honest input on the john deee z910

Hello, i am new here,but definately not the industry. Just curious if anyone here has owned/run the jd z910, and what you think of it. I just ordered one to replace my second problematic x540 in as many seasons. I realize it is only 22hp, but it will only be mowing 1.5acres of fairly level yards. I opted for the 54" deck, so it would have the wider tires. We currently run a 4720 and 2 deere wam's to mow a couple of large esates w/grass runways on them. I just bought this z910 for my home property. Any positive input would be greatly appreciated.
Reply With Quote
  #2  
Old 10-23-2011, 09:09 AM
Jimslawncareservice Jimslawncareservice is online now
LawnSite Gold Member
 
Join Date: Mar 2008
Location: mn
Posts: 3,947
Normally people ask this before they buy. Well anyway I have a z950. No problems does great on hills. Does great in wet or dry grass, talk or short, weedy or pure lush grass. Only problem is with the kawi. Mine uses oil and they don't know why. I have a 1xx hours on it. I bought it early-mid summer.
Posted via Mobile Device
Reply With Quote
  #3  
Old 10-23-2011, 10:18 AM
mowerbrad's Avatar
mowerbrad mowerbrad is online now
LawnSite Fanatic
 
Join Date: Jan 2008
Location: Grand Haven, Michigan
Posts: 6,269
The only issue you may have with the Z910 is related to power. From what I hear, they do run quite well even with the 22hp engine. My Z925 has 27hp with the 54" MOD deck, that has more than enough power for side discharging and mulching. So I would assume that 22hp should do well just side discharging and you shouldn't have too many problems with the power...I'd assume only on hills or when cutting heavy growth.

From the sounds of it, the Z910 will do well on your property. I think you'll like it.
__________________
'07 Chevy 2500HD
2010 John Deere Z925A 54" MOD
2011 John Deere Quik Trak 647A
John Deere walkbehind
81"x18' trailer
Stihl handhelds
Reply With Quote
  #4  
Old 10-23-2011, 12:14 PM
485DEERE 485DEERE is offline
LawnSite Member
 
Join Date: Oct 2011
Location: INDIANA
Posts: 13
Quote:
Originally Posted by Jimslawncareservice View Post
Normally people ask this before they buy. Well anyway I have a z950. No problems does great on hills. Does great in wet or dry grass, talk or short, weedy or pure lush grass. Only problem is with the kawi. Mine uses oil and they don't know why. I have a 1xx hours on it. I bought it early-mid summer.
Posted via Mobile Device
i would be checking valve guides/seals, kawi has had issue in the past. thanks to all who replied, anyone else have input?
Reply With Quote
  #5  
Old 10-23-2011, 12:17 PM
Jimslawncareservice Jimslawncareservice is online now
LawnSite Gold Member
 
Join Date: Mar 2008
Location: mn
Posts: 3,947
Since its under warranty I'm letting deere handle it
Posted via Mobile Device
Reply With Quote
  #6  
Old 10-23-2011, 09:40 PM
LawnCareNoobie's Avatar
LawnCareNoobie LawnCareNoobie is offline
LawnSite Senior Member
 
Join Date: Jan 2008
Location: Rochester, NY
Posts: 425
Quote:
Originally Posted by Jimslawncareservice View Post
Normally people ask this before they buy. Well anyway I have a z950. No problems does great on hills. Does great in wet or dry grass, talk or short, weedy or pure lush grass. Only problem is with the kawi. Mine uses oil and they don't know why. I have a 1xx hours on it. I bought it early-mid summer.
Posted via Mobile Device
Yep, my 925a's Kawasaki is using up oil too.

Do you ever get white smoke when starting up the mower? I see it now and then. I have warranty still as well, so it's definitely going to get taken care of.
Reply With Quote
  #7  
Old 10-23-2011, 09:44 PM
LawnCareNoobie's Avatar
LawnCareNoobie LawnCareNoobie is offline
LawnSite Senior Member
 
Join Date: Jan 2008
Location: Rochester, NY
Posts: 425
Quote:
Originally Posted by 485DEERE View Post
Hello, i am new here,but definately not the industry. Just curious if anyone here has owned/run the jd z910, and what you think of it. I just ordered one to replace my second problematic x540 in as many seasons. I realize it is only 22hp, but it will only be mowing 1.5acres of fairly level yards. I opted for the 54" deck, so it would have the wider tires. We currently run a 4720 and 2 deere wam's to mow a couple of large esates w/grass runways on them. I just bought this z910 for my home property. Any positive input would be greatly appreciated.
Should be a great mower for your property. I haven't had any issues with my mower (925a). I love it.

Just curious, what were the problems with the x540 that you were experiencing?
Reply With Quote
  #8  
Old 10-23-2011, 09:44 PM
Jimslawncareservice Jimslawncareservice is online now
LawnSite Gold Member
 
Join Date: Mar 2008
Location: mn
Posts: 3,947
Yes I see that smoke too. It smells like burnt Bacon
Posted via Mobile Device
Reply With Quote
  #9  
Old 10-23-2011, 10:53 PM
ramcat ramcat is offline
LawnSite Member
 
Join Date: Oct 2008
Location: Mount Calvary, Wisconsin
Posts: 211
our z950 smokes just a little on a cold start but if it only smokes on a cold start i would not worry about it. it smells bad and probably isn't ideal but at least in my situation it barely uses oil and we have almost 1100 hours on ours. no problems except a few deck belts.
Reply With Quote
  #10  
Old 10-24-2011, 05:18 AM
485DEERE 485DEERE is offline
LawnSite Member
 
Join Date: Oct 2011
Location: INDIANA
Posts: 13
Quote:
Originally Posted by LawnCareNoobie View Post
Should be a great mower for your property. I haven't had any issues with my mower (925a). I love it.

Just curious, what were the problems with the x540 that you were experiencing?
they are great tractors except for one thing. the last 2 i owned, 2 in 2 years that is,i could not keep pto clutch bearings,or idler arm bearings in them. every 35-40hrs i had to replace them.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 06:44 PM.

Page generated in 0.07592 seconds with 8 queries