Register free!

The Green Industry's Resource Center


 
 
Thread Tools   Display Modes
  #1  
Old 10-25-2011, 01:12 PM
bieriewk bieriewk is offline
LawnSite Member
 
Join Date: Aug 2011
Location: Swanton, Ohio
Posts: 4
Throttle cable issues?

Hi all, I have a 2010 Z4, with 50 hours, and the stock throttle cable has acted up since day one. recently, it quit working all together, and the dealer said there were some re-inforced ones available for a different machine. They ordered the cable, but I needed to be cutting, and they didn't have time to install it right away. So they handed me the cable, showed me how to install, and I did the work. After installing, the plastic clip at the handle broke the first time I tried to throttle up. I examined the original cable/bracket assembly, and noticed the bracket was bent. I am tempted to bend the bracket back and weld a gusset in to reinforce it, because this "other cable" did not hold up. Anyone else have issues with this? My machine has a 25HP kawi, and is a 54" deck. Any recommendations? I don't want to have just another stock set-up installed, because this obviously isn't sufficient.
  #2  
Old 10-26-2011, 01:08 PM
mowerconsultant's Avatar
mowerconsultant mowerconsultant is offline
LawnSite Fanatic
 
Join Date: Feb 2000
Location: Syracuse, NY
Posts: 9,755
The 601675 cable is the part # you need and if installed correctly should last a long time.
I am not sure why the ones you had failed but I would have the dealer install the correct cable under warranty and make sure its adjusted correctly.
I have looked and I don't see any notes in our system or updates to the cable or the adjustment.

Pj
__________________
  #3  
Old 10-26-2011, 11:50 PM
bieriewk bieriewk is offline
LawnSite Member
 
Join Date: Aug 2011
Location: Swanton, Ohio
Posts: 4
I discovered that the cable was not the issue, that the linkage it connects to was bent, and binding. I bent it back, and as soon as possible it will be returning to the dealer. I appreciate the response.
  #4  
Old 11-01-2011, 10:07 AM
mowerconsultant's Avatar
mowerconsultant mowerconsultant is offline
LawnSite Fanatic
 
Join Date: Feb 2000
Location: Syracuse, NY
Posts: 9,755
Quote:
Originally Posted by bieriewk View Post
I discovered that the cable was not the issue, that the linkage it connects to was bent, and binding. I bent it back, and as soon as possible it will be returning to the dealer. I appreciate the response.
Ok.
The linkage on the engine was bent?

Pj
__________________
  #5  
Old 04-22-2012, 07:06 PM
dualsmows dualsmows is offline
LawnSite Member
 
Join Date: Jan 2007
Location: Colchester Illinois
Posts: 93
My 3rd cable in a year just went out again. The plastic pc. that keeps the engine on high speed keeps wearing out.
Do you have any ideas?

Thank You
__________________
Hustler X1
Landpride Z60
Landpride ZT60
Hustler Super Z
Snapper Pro 61
Stihl Trimmers
Echo Blowers
20' Tandem trailer

22 YEARS IN THE COMMERCIAL MOWING BUSINESS!


DOOLEY MOWING SERVICE
COLCHESTER IL.
  #6  
Old 04-23-2012, 04:35 PM
mowerconsultant's Avatar
mowerconsultant mowerconsultant is offline
LawnSite Fanatic
 
Join Date: Feb 2000
Location: Syracuse, NY
Posts: 9,755
Plastic piece? in the linkage / cable handle? or control plate? or on the carb?
__________________
  #7  
Old 04-23-2012, 06:23 PM
Mickhippy's Avatar
Mickhippy Mickhippy is offline
LawnSite Platinum Member
 
Join Date: Feb 2003
Location: Queensland, Australia.
Posts: 4,034
Im not really mechanical so dont know what these things are called but I'll try to explain as well as I can...

Where the outer "sheath" gets held onto the engine, Its like a small rectangle clip that holds the end of the sheath and lines it up with the throttle "bit" on the engine. the cable can fit in either a high or lower position. I snapped probably 3 cables last season because they were being fitted in the (I think) lower position. I got a new cable, put in higher position and its been sweet ever since.

Basically, the sheath/cable wasnt lining up correctly with the throttle "lever" on the engine.

Sorry for the vague names/explanation but just check that the cable is lining up correctly.
  #8  
Old 04-23-2012, 07:37 PM
dualsmows dualsmows is offline
LawnSite Member
 
Join Date: Jan 2007
Location: Colchester Illinois
Posts: 93
The part im referring to is on the throttle handle itself.
__________________
Hustler X1
Landpride Z60
Landpride ZT60
Hustler Super Z
Snapper Pro 61
Stihl Trimmers
Echo Blowers
20' Tandem trailer

22 YEARS IN THE COMMERCIAL MOWING BUSINESS!


DOOLEY MOWING SERVICE
COLCHESTER IL.
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Layout Style:





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.com™ - Moose River Media
All times are GMT -4. The time now is 01:10 PM.

Page generated in 0.08739 seconds with 7 queries