Register free!

The Green Industry's Resource Center


 
 
Thread Tools   Display Modes
  #1  
Old 04-02-2012, 12:52 PM
glamis500 glamis500 is offline
LawnSite Member
 
Join Date: May 2007
Location: Keystone Heighs, FL
Posts: 1
2007 19/52 mini-z won't crank

Model: 927491
Ser: 07042183
Hours: 104.2

Second time I've used it this season. Battery fully charged. Red panel light comes on. No click when I turn the key. Verified the safety switches in the seat, steering levers had continuity. Blade clutch clicks when I move the switch.

It will start and run with the key on and by jumping B+ to the starter solenoid (red wire/black tracer). All three fuses are good.

Searched the archives for similar problem that was specific to this model with no joy.

Suspect a faulty relay somewhere - Any help would be greatly appreciated.
  #2  
Old 04-03-2012, 09:52 PM
mowerconsultant's Avatar
mowerconsultant mowerconsultant is offline
LawnSite Fanatic
 
Join Date: Feb 2000
Location: Syracuse, NY
Posts: 9,755
I replied to your email.
Sounds like a relay or solenoid.

Pj
__________________
  #3  
Old 04-04-2012, 04:41 AM
glamis500 glamis500 is offline
LawnSite Member
 
Join Date: May 2007
Location: Keystone Heighs, FL
Posts: 1
Thanks PJ for all of your help. Work has kept me away from further troubleshooting but I'm sure you're right about the faulty relay.

Any idea why it takes so long for posts to appear?
  #4  
Old 04-04-2012, 05:56 PM
mowerconsultant's Avatar
mowerconsultant mowerconsultant is offline
LawnSite Fanatic
 
Join Date: Feb 2000
Location: Syracuse, NY
Posts: 9,755
Quote:
Originally Posted by glamis500 View Post
Thanks PJ for all of your help. Work has kept me away from further troubleshooting but I'm sure you're right about the faulty relay.

Any idea why it takes so long for posts to appear?
Let us know what you find out.
This is a moderated forum, when you post a question or comment it then goes into a moderator Que, I release the posts a few times a week if not everyday and then I answer them accordingly.

Pj
__________________
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Layout Style:





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.com™ - Moose River Media
All times are GMT -4. The time now is 12:45 PM.

Page generated in 0.07326 seconds with 10 queries