Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 04-30-2012, 04:40 PM
Glennw Glennw is offline
LawnSite Member
 
Join Date: Apr 2012
Posts: 1
John Deere SB14 Starting problem

I have a SB 14 and am having trouble starting it. When I pull the cord, it became very very hard to pull. And when I do it sound like a organ grinder. I did get the engine to start and it ran for 2-3 minutes before it died. No smoke, or burned smell, so I don't think it's frozen.

The local JD dealer told me he thought it was the blade clutch and they’d be happy to fix it for 250.00.

Is a blade clutch hard to fix (replace)? Could this be the problem?

I love this mower and have had it for 10+ year without a lot of problems. And really don’t want to replace it!
Thanks
Reply With Quote
  #2  
Old 04-30-2012, 04:55 PM
Ridin' Green Ridin' Green is offline
LawnSite Fanatic
 
Join Date: May 2011
Location: Michigan
Posts: 8,204
With the grinding noise I'd bet your blade clutch is the problem. I haven't ever changed mine, so I don't know how hard it would be, but there's really not that much to a 21"er, so it can't be that hard.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.com™ - Moose River Media
All times are GMT -4. The time now is 01:31 PM.

Page generated in 0.06269 seconds with 9 queries