Register free!
Search
 
     

The Green Industry's Resource Center


Click for Weather
Reply
 
Thread Tools Display Modes
  #1  
Old 05-11-2012, 07:05 PM
agent walker agent walker is online now
LawnSite Senior Member
 
Join Date: Feb 2011
Location: Sesser,IL
Posts: 387
wtb permagreen ultra engine

i'm in dire need of a briggs engine for a permagreen ultra. the stud that the alternator bolts to broke off and cant be fixed and since its part of the housing the whole engine needs replaced and briggs no longer makes that engine or any other with the aux pto so i'm sunk unless somebody has used engine around, maybe after they upgraded to the ultra x? i'm not into investing that much into the upgrade at this point, since i'd like a permagreen with biggger tank anyway.
Reply With Quote
  #2  
Old 05-11-2012, 10:20 PM
phillie's Avatar
phillie phillie is offline
LawnSite Senior Member
 
Join Date: Feb 2010
Location: indianapolis, in
Posts: 845
Man, good luck.. My mechanic was telling me how hard it is to get an Ultra engine right now. Hope you find one.
Reply With Quote
  #3  
Old 05-12-2012, 08:49 AM
Reassurance Property Reassurance Property is offline
LawnSite Member
 
Join Date: Jul 2007
Location: Nisswa Minnesota
Posts: 124
If you do upgrade try to find a magnum. I got the triumph, and though it's a good machine I thing the ultra and magnum were better. They changed a lot of stupid things that don't really work that well.
__________________
Too much to list
Reply With Quote
  #4  
Old 05-14-2012, 08:38 PM
jbturf jbturf is online now
LawnSite Bronze Member
 
Join Date: Sep 2007
Location: groton, MA
Posts: 1,304
check out this thread

may be of help for you

http://www.lawnsite.com/showthread.php?t=290057
Reply With Quote
  #5  
Old 05-15-2012, 07:18 AM
cleanponds cleanponds is offline
LawnSite Member
 
Join Date: Jan 2011
Location: NW Ohio
Posts: 23
If you do not use the sprayer you can still spread dry without the alt if that helps.If your talking about the bracket under the flywheel.
Reply With Quote
  #6  
Old 05-15-2012, 09:27 PM
agent walker agent walker is online now
LawnSite Senior Member
 
Join Date: Feb 2011
Location: Sesser,IL
Posts: 387
yes, thats what i'm doing now. i just finished up with broadleaf herbicide when it went out. i can charge battery externally and pump will still work, but i'd like it working right! also, the tach no longer works, and i don't think the hour meter is right either. and i have to disconect the kill wire or it won't start. had same problem last year and replaced wiring harness with that control module thingy and that fixed it. any idea whats wrong? I don't like blowing 70 bucks every 20hrs.
Reply With Quote
  #7  
Old 05-16-2012, 07:15 AM
cleanponds cleanponds is offline
LawnSite Member
 
Join Date: Jan 2011
Location: NW Ohio
Posts: 23
Is your bracket under the flywheel broken, It has two mounting points and that is your altenator. Your flywheel will have magnets glued "inside" of it.The outside magnet powers your "coil" The wire coming from the alternator will go to a voltage regulator.
Reply With Quote
Reply

Tags
fertilizer , lesco , permagreen , ultra , zspray

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2012, LawnSite.comô - Moose River Media
All times are GMT -4. The time now is 11:03 PM.

Page generated in 0.07480 seconds with 7 queries